4

It is my first time using a MIDI keyboard. When connect to the computer I have no idea if it is working. I want to use in Musescore but it also do not respond to the keyboard.

I'm using an old "Yamaha PSR-520" and a "CH345 MIDI 1" controller from Alliexpress.

4

It's not needed to install any program.

Musescore by default was not using ALSA audio on my installation. It was only needed to select ALSA at preferences menu and it just worked!

preferences menu

to see if the MIDI was recognized just type aconnect -i

pauloh@mccartney:~$ aconnect -i
client 0: 'System' [type=kernel]
    0 'Timer           '
    1 'Announce        '
client 14: 'Midi Through' [type=kernel]
    0 'Midi Through Port-0'
client 20: 'CH345' [type=kernel]
    0 'CH345 MIDI 1    '

This last 'CH345' is my MIDI controller and it is shown only when connected.

To more details about MIDI I read this article from Rafał Cieślak

1

You need to select PortAudio into MuseScore Preferences I/O panel.

Please, check about the very important parameters:

1) API: To me, at least, it should be ALSA

2) Audio Device: System Default

3) MIDI Input, and MIDI Output: You have to select your recognized external MIDI device here.

Then... Close MuseScore and Open it again.

You will be able to use the external MIDI device BUT... There is some "bugs" because the internal MuseScore way to play the score (it is not full General MIDI Standard compatible).

0

The solution from Paulo Henrique didn't work for me. I had to select the "Port Audio" check box. Even though the drop down didn't show any content. You have to make sure that you first turn on your MIDI-keyboard and then start Musescore in order to make the MIDI-Input working.

The output of aconnect -i is

$ aconnect -i
client 0: 'System' [type=kernel]
    0 'Timer           '
    1 'Announce        '
client 14: 'Midi Through' [type=kernel]
    0 'Midi Through Port-0'
client 24: 'YAMAHA Portatone' [type=kernel]
    0 'YAMAHA Portatone MIDI 1'
client 128: 'MuseScore' [type=user]
    2 'MuseScore Port-0'
0

In the new MuseScore 3, I couldn't find an ALSA option, until I checked the PortAudio box (I'm on Ubuntu 18.04 LTS):

enter image description here

Seems like they integrated it.

Don't forget to first turn on the piano (and connect it) and then start MuseScore. Works great with the Yamaha P-45 which I connected through USB (which I used here).

me@mycomputer:~$ aconnect -i
client 0: 'System' [type=kernel]
    0 'Timer           '
    1 'Announce        '
client 14: 'Midi Through' [type=kernel]
    0 'Midi Through Port-0'
client 20: 'Digital Piano' [type=kernel,card=1]
    0 'Digital Piano MIDI 1'

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.