5

I'm following this guide to install WPS Office but when I run the dpkg command, the following appears in the terminal:

(Reading database ... 291111 files and directories currently installed.)
Preparing to unpack wps-office.deb ...
Unpacking wps-office (10.1.0.5672~a21) over (10.1.0.5672~a21) ...
dpkg: dependency problems prevent configuration of wps-office:
 wps-office depends on libpng12-0; however:
  Package libpng12-0 is not installed.

dpkg: error processing package wps-office (--install):
 dependency problems - leaving unconfigured
Processing triggers for bamfdaemon (0.5.3+17.04.20170406-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for gnome-menus (3.13.3-6ubuntu5) ...
Processing triggers for desktop-file-utils (0.23-1ubuntu2) ...
Processing triggers for mime-support (3.60ubuntu1) ...
Processing triggers for shared-mime-info (1.8-1) ...
Processing triggers for hicolor-icon-theme (0.15-1) ...
Errors were encountered while processing:
 wps-office

Then, when I run:

sudo apt-get install -f && rm wps-office.deb

The following is output:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages will be REMOVED:
  wps-office
0 upgraded, 0 newly installed, 1 to remove and 1 not upgraded.
1 not fully installed or removed.
After this operation, 367 MB disk space will be freed.
Do you want to continue? [Y/n] n
Abort.

I switched to Ubuntu from ChromeOS about a week and a half ago so this is all very new to me and any help you can give would be greatly appreciated.

0
5

Apparently, you don't have package libpng12-0 installed. Download the correct one for your architecture.

Then open terminal and run the command below to install libpng12-0 package

sudo dpkg -i libpng12-0_1.2.50-2+deb8u2_amd64.deb

For 64-bit, or

sudo dpkg -i libpng12-0_1.2.50-2+deb8u3_i386.deb

For 32-bit

And then run

sudo dpkg -i wps-office_10.1.0.5672~a21_amd64.deb

To install WPS Office.

1

install libpng first then install WPS Office.

dpkg is usually good about satisfying dependencies, so libpng might not be available from your current repositories.

you can get it here: https://packages.ubuntu.com/trusty/libpng12-0

Not the answer you're looking for? Browse other questions tagged or ask your own question.