0

This question already has an answer here:

When I try to start gnome terminal from launcher, nothing happens. except terminal Icon starts glowing for a few seconds and then nothing ....

But when I try to open it through urxvt, It starts without any kind of error or output.

marked as duplicate by Jacob Vlijm, David Foerster, Zanna, Eric Carvalho, user364819 Jun 20 '17 at 8:19

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Try start it from another terminal and check output. – BlueManCZ Jun 18 '17 at 11:33
  • @BlueManCZ Tried it in xterm and xfce4 terminal. no difference – A.Esm.T Jun 18 '17 at 12:05
  • Yes, but was there any warning or error message? – BlueManCZ Jun 18 '17 at 12:50
  • @BlueManCZ no difference ! no there was not any error message in urxvt nor in xterm or xfce terminal. – A.Esm.T Jun 18 '17 at 12:55
  • @BlueManCZ I just started it in i3wm. it worked perfectly. so the problem is unity (probably) – A.Esm.T Jun 18 '17 at 12:56
0

There can be problem with launcher command which starts aplication.

Install alacarte, run it, find gnome-terminal launcher, open properties and insert command which work for you into input for command. In your case gnome-terminal or /usr/bin/gnome-terminal. Than save changes.

  • it worked. but I really want to solve the real problem. what is wrong with gnome-terminal-server ?? why it doesn't work? – A.Esm.T Jun 18 '17 at 16:09
  • I don't use Ubuntu, but Debian. Here I have Gnome and in my gnome-terminal launcher there is default command gnome-terminal. Command gnome-terminal-server or any package with this name doesn't exist here. So you should wait for some Ubuntu guru. – BlueManCZ Jun 18 '17 at 16:33
  • @A.Esm.T gnome-terminal-server is the process name, gnome-terminal the command to run gnome-terminal. – Jacob Vlijm Jun 18 '17 at 17:47

Not the answer you're looking for? Browse other questions tagged or ask your own question.