I've using ubuntu dual boot with windows for years, since jaunty jackalope i think. i usually make three partition; 1 ntfs for windows system (C:), 1 ntfs for data storage and ext3/4 for linux. at first i could mount and access my ntfs C: and data ntfs out the box. but since the nth upgrade of lucid or precise (i dont remember) until now, nautilus stop to display the contents of C: (windows 7 system partition), but the data partition works well as usual. it seems that the drive c: is mounted, and the properties display correct usage of the drive, but i still cant see the files inside the drive in the file manager. i've searched on the web but no result, most of the cases are windows partition cannot be mounted. I need to share my Download folder in windows with ubuntu while im working with ubuntu. Anyone can help?

  • 1
    It would help if you formatted and broke down that wall of text into easily “digestible” paragraphs. The title sounds like I can help you but I, like many people here (and elsewhere), can't be bothered to read paragraphs as long as the one in the current edition of your question unless they have a good incentive. Jun 20, 2017 at 15:34
  • Could you please edit your question to include the output of sudo lsblk -f? Thanks. Jun 20, 2017 at 15:35

1 Answer 1


Try mounting it through the terminal by creating a folder to mount to with

sudo mkdir /mnt/windows

finding the partition with

sudo fdisk-l

Then with the partition you want,

sudo mount -t ntfs (disk partition) /mnt/windows

Then in nautilus, go to /mnt/windows

If it still doesn't work, then try

sudo apt install --reinstall ntfs-3g
  • Thank u NerdOfLinux for ur response. the partition is mounted, but nautilus still blank page, cant see the files inside. It seems to me that it's about the option in mounting process, but I dont understand the choices and how to use 'em. which option that prevent the file manager to display the contents of the partition. Any idea Nerd? Jun 18, 2017 at 1:44
  • Sorry, I had a typo, please try it again now.
    – user669400
    Jun 18, 2017 at 1:46
  • it's ok, I already fixed that. but still no result. Jun 18, 2017 at 1:57
  • Can you access it via the terminal with cd /mnt/windows
    – user669400
    Jun 18, 2017 at 2:01
  • it shows like this: Jun 18, 2017 at 2:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .