8

I am using Ubuntu 17.04 on my Dell XPS 15 9550. I am having trouble using my headphones, the laptop does not recognize them and there is no sign when I plug them in. I have tried the options suggested by people online but none of them seem to work.

So far I have tried:

  • Please list in your question all of the things you've tried already to solve your problem. – jones0610 Jun 17 '17 at 23:40
  • Same problem with DELL XPS12. With ubuntu 16.04, it worked fine. With 16.10 I didn't try. – norteo Jul 7 '17 at 18:39
  • 1
    It's an official issue and people complained about this in 2016 already. There are some solutions for Ubuntu BEFORE 17.10 in the official issue but none of theme is working for me in 17.10 though. – Wurstsalat Nov 13 '17 at 12:08
  • For me, the only thing that worked was to power off the laptop, remove the power cable and all other connections, and let it rest for 2 minutes. When I powered it up, it was good. It seems that sometimes the bios mixes the headphones port voltage and alsa can't work with that. – Gotcha Jul 13 '18 at 9:48
5

I think I solved the problem for my XPS12. The answer is based on this question: Microphone is not working on Ubuntu 16.04

  • I executed hdajackretask (see image in the question mentioned above)
  • I checked the "Show unconnected pins" check-box
  • For every "pin" that had a "Headphones" option in its drop-down, I checked the "override" check-box and selected the "Headphones" option.
  • I clicked the "Install boot override" button.
  • I restarted, and the speakers worked fine.

Something important to note is that if you just play with other possibilities and press apply, for some reason, in my case, switching back and forward the same option, sometimes didn't work...

Another thing to note is that, after rebooting, I opened the hdajackretask and the options didn't look exactly the same way I left them before reboot...

Bottom line: the headphones/speakers now work for me.

Good luck!

  • I love you man. I tried all sort of things for hours and this finally worked. – Paul Brodersen Nov 25 '17 at 16:23
3

I have the same machine and the same distro. Unfortunately more of a hack but it works fine for me:

Don't have your headphones plugged in when you start the laptop, plug them in once its fully started up and you are logged in. Fixes the problem for me.

2

I’d recommend trying

alsa force-reload 

If that doesn’t fix the issue, then try

pulseaudio -k

If it still won’t work, try

pulseaudio

If all else fails try

sudo apt install —reinstall pulseaudio alsa-base
  • Same answer basically? – NerdOfCode Jun 18 '17 at 1:16
1

Try killall pulseaudio, and if that does not work try pulseaudio -k. Please let me know how this works!!!

  • Neither works for me on 18.04, unfortunately – aidan Sep 1 '18 at 6:03
0

This worked for me. I removed alsa packages and then after rebooting the system everything worked fine. I think you need to re-install driver again: sudo apt-get --purge remove linux-sound-base alsa-base alsa-utils

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.