18

I make a selection of a part of an image because I want to crop it, and Pinta immediately crashes. I removed Pinta with purge and reinstalled, but the problem persists.

The error message is:

Pinta.exe assert failure: Error in usr/bin/mono: double free or corruption (out): 0x000005579etc.

In the UnreportableReason section of the error message I'm told that I have some obsolete package versions installed (libgssapi-krb-5-2, libk5crypto3, libkrb5-3, libkrb5support0, libssl1.0.0).

Upgraded, restarted, but I still get the crashes.

I use Ubuntu 17.04.

Any suggestions?

  • 1
    Did you do both sudo apt update and sudo apt upgrade? – Soren A Jun 17 '17 at 14:27
  • No, I only did upgrade. Should I have run update as well? – Alexandru Mircea Jun 17 '17 at 14:44
  • 1
    Fairly new with Ubuntu, I see that update should preceed upgrade. Is that right? – Alexandru Mircea Jun 17 '17 at 14:46
  • 1
    Yes., sudo apt update updates the local database over available packages and versions thereof. sudo apt upgrade does the actual upgrade of your system's installed software. – Soren A Jun 17 '17 at 15:01
  • To all who will eventually read this, I installed Shutter as a replacement for Pinta. After one day of use, I can tell it's much much better, having much more functionality. – Alexandru Mircea Jun 19 '17 at 21:13
18
+350

Probably it's Mono problem and seemly v4.4.1 or older or dependently in some versions only.

Try once install/keep up-to-date the Mono by the following command (Ubuntu 18.04):

sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 3FA7E0328081BFF6A14DA29AA6A19B38D3D831EF
echo "deb https://download.mono-project.com/repo/ubuntu stable-bionic main" | sudo tee /etc/apt/sources.list.d/mono-official-stable.list
sudo apt update
sudo apt install mono-devel

Or in older Ubuntu please follow instructions mentioned here.

Sometimes installing mono-runtime package would be enough to fix that.

You may also need to follow 3rd step in instructions and do Installation Verification.

If Mono was working fine then you should not have crash problems when using crop in Pinta as well.

You may need to try with different versions of Mono to get it to work.

  • 1
    Okay, this did fix the problem apparently. seems the crash (which I mentioned in my now deleted comment) was unrelated. – RolandiXor Sep 18 '17 at 7:49
  • At least you need to tell us in which version of Mono on Ubuntu 17.04 you get this fixed : ) – αғsнιη Sep 18 '17 at 9:18
  • What-ever came with that PPA (mono-devel is the package I installed but I didn't check the version, lol). Unfortunately, it seems not to have solved every issue. Certain actions are still producing an instantaneous crash, but there's nothing we can do - the developer hasn't had time to work on it (Pinta) in a while and no one else has stepped up. Maybe I can provide more details later (I should be sleeping). – RolandiXor Sep 18 '17 at 9:33
  • This conversation has been moved to chat. – RolandiXor Sep 18 '17 at 9:34
  • 1
    Latest mono didn't work for me on 17.04. Any alternatives to pinta? – Abe Petrillo Oct 20 '17 at 21:45
0

It is a known bug

Pinta constantly crashes in Ubuntu 18.04 fresh install

https://bugs.launchpad.net/pinta/+bug/1786822

Installing Mono MAY help (not guaranteed)

https://www.mono-project.com/download/stable/#download-lin

It seems like certain actions - for example drawing a selection box, clicking somewhere, then leaving Pinta for a bit, is a workaround for it not to crash. Not consistent enough to say with certainty.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.