I have recently created a dual boot ubuntu 16.04. It seems to have trouble when connecting to my wifi network - after inserting the password the connection icon in network manager is 'running' and then it just disconnects. On rare occasions (after few reboots/plug and unplug wireless adapter/reconnect) it manages to connect and then it's fine. I can also maintain a normal wired connection. I read several other topics related to this matter but neither of them did help. I attach the wireless info file:


Thanks, Maks

1 Answer 1


Your wireless_info shows two access points with the same name, same signal strength and so on. It also clearly shows attempts to roam from among the two, disconnects, reconnects, etc. We don't understand why. If you have any understanding of this, we suggest that it be changed. At the least, rename one of the instances to NETIASPOT-5EE530A or some such.

If you are unable to do so, I suggest that you ask Network Manager to bind to one instance or the other by referencing the MAC address, like this: Ubuntu connect drops. Worked for a while then started dropping again

We are very concerned about the encryption in your router:

IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP
                        Authentication Suites (1) : PSK
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP
                        Authentication Suites (1) : PSK

WPA2-AES is preferred; not any WPA and WPA2 mixed mode and certainly not TKIP. Second, if your router is capable of N speeds, you may have better connectivity with a channel width of 20 MHz in the 2.4 GHz band instead of automatic 20/40 MHz, although it is likely to affect N speeds. I also have better luck with a fixed channel, either 1, 6 or 11, rather than automatic channel selection. Also, be certain the router is not set to use N speeds only; auto B, G and N is preferred. After making these changes, reboot the router.

Next, I recommend that your regulatory domain be set explicitly. Check yours:

sudo iw reg get

If you get 00, that is a one-size-maybe-fits-all setting. Find yours here: http://en.wikipedia.org/wiki/ISO_3166-1_alpha-2 Then set it temporarily:

sudo iw reg set IS

Of course, substitute your country code if not Iceland. Set it permanently:

gksudo gedit /etc/default/crda

Use nano or kate or leafpad if you don't have the text editor gedit.

Change the last line to read:


Proofread carefully, save and close the text editor.

Next, I'd set IPv6 to Ignore in Network Manager: http://docs.fedoraproject.org/en-US/Fedora/18/html/Installation_Guide/images/netconfig/network-connections-ipv6-ignore.png This example is for ethernet, but you want wireless.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .