I'm using Ubuntu 16.04.2 Xenial and I was trying to install mesa with this method.

I did this in the terminal.

sudo add-apt-repository ppa:ubuntu-x-swat/updates
sudo apt update && sudo apt dist-upgrade
sudo reboot

but it messed up now I can't boot all my linux kernel from oldest to latest and because of that I tried to remove that ppa using

sudo apt-get install ppa-purge
sudo ppa-purge ppa:ubuntu-x-swat/updates
sudo add-apt-repository --remove ppa:ubuntu-x-swat/updates
sudo apt update && sudo reboot

but didn't work I also tried removing and purging all my kernel and install the same version same result didn't work I also tried using Boot-Repair stil didn't work I also tried using other boot loader but all of them is not working and I tried resetting my ppa's and then sudo apt update but it didn't fix the problem. Now I'm currently using Lubuntu 17.04 in my usb that has 3.5 GB storage

Thanks in advance,

  • How are you sure about the cause of the problem? Logically this cannot be the reason behind your problem. May you mention what you get as error while booting your system? Jun 17, 2017 at 10:35
  • Uhmm, no error when booting but the resolution is changed and it's stucked in black screen and not really sure that's the cause because after I did add that ppa I can't boot
    – Glenn
    Jun 17, 2017 at 10:51
  • While seeing black screen, press TAB or Esc button. Can you see anything? if not, through a live USB, try to get access to your syslog and see what are at the end of it Jun 17, 2017 at 10:54
  • I tried CTRL+ALT+F1 and I can see the tty1 and after a few seconds it will come back to the black screen and I don't know where to find syslog
    – Glenn
    Jun 17, 2017 at 11:15
  • Boot using live USB and mount your current installation partition. you will find syslog in MOUNTPOINT/var/log/syslog Jun 17, 2017 at 13:56

1 Answer 1


I can't believe it I fixed it using

apt-get install --install-recommends xserver-xorg-hwe-16.04

and it made my xenial faster than before but the screen resolution is mess up I need to manually set the right resolution.

  • How did you come to know that this would help you solving the problem? Jun 19, 2017 at 12:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .