Please see this video for bios error messages.

I bought a Lenovo Ideapad 100S 11IBY that has 32bit-uefi boot. It came with Windows 10 but b it is a Intel Atom laptop and I wanted to install lxde Linux on it to use its resources well.

After a lot of online research I managed to create a UEFI 32-bit bootable lubuntu USB using linuxium (lubuntu with kernel patch for baytrail processor), and it worked!

I was happy with the installation but yesterday I decided I wanted to install mate desktop environment through terminal. After a reboot the laptop never booted to Ubuntu.

These Error messages appear again and again.:

Ubuntu failed to boot


boot device missing

I have tried all sorts of 32bit uefi bootable usbs, windows 10 recovery USB, and windows 10 installation USB but nothing boots.

On the boot menu I just see two repeated optiond, both options say "Ubuntu" and both fail to boot.

Can someone help me either installing back windows 10 or somehow get PST the boot errors? See the linked video at the top for error messages on my screen.

  • is secure boot on? try without secure boot. – ravery Jun 17 '17 at 7:58
  • How did you install Mate? – Mostafa Ahangarha Jun 17 '17 at 10:53
  • @ravery : I tried with both SecureBoot on and off. It still does not boot. The messages are exactly the same as you saw on the linked video. – oodNinja Jun 17 '17 at 17:26
  • @Mostafa Ahangarha: Lubuntu was working properly but then I installed Mate desktop enviro by sudo apt install mate-core mate-desktop-environment. After the reboot, it all broke. At this point, I will be happy just with formatting the eMMC storage and reinstalling Windows 10 or just getting through to linux terminal. I know what to do after that. Thanks for your help. – oodNinja Jun 17 '17 at 17:30
  • This is NOT a duplicate of the question to which David linked; that's a generic installation question, whereas this one is about breakage of GRUB on a 32-bit UEFI (known, in technical terms, as weird) system. – Rod Smith Jun 17 '17 at 19:31

I'm not 100% certain, but my hunch is that your package update pulled in an update of GRUB that broke your installation. Perhaps this was a switch from an EFI-mode to a BIOS-mode GRUB, with corresponding changes to GRUB's configuration file that broke the EFI-mode GRUB; or perhaps it was a more general GRUB breakage.

My suggestion, at least for a short-term fix, is to use my rEFInd boot manager:

  1. Download the USB flash drive or CD-R image of rEFInd from its downloads page.
  2. Prepare a boot medium with the image you obtain.
  3. Disable Secure Boot on the computer. (It can be done with Secure Boot active, but doing so would require jumping through quite a few extra hoops.)
  4. Boot to the rEFInd USB drive or CD-R.
  5. rEFInd should appear and enable you to boot both Windows and Ubuntu. (There may be extra boot options, some of which might not work.) Test to be sure that both Windows and Ubuntu can boot.
  6. If you can boot both Windows and Ubuntu, you can either:
    • Use the ability to boot both OSes as a temporary breather while you attempt to better diagnose and fix the problem. You might use grub-install or Boot Repair to re-install GRUB, for instance. (I don't know how well Boot Repair would work on a 32-bit UEFI system, though.)
    • Install rEFInd to your hard disk by using the PPA or Debian package (or the standard Ubuntu repos, if you're using Ubuntu 17.04). This will then bypass GRUB on a permanent basis.

Note that this is not guaranteed to work. Even if it fails, though, it may provide helpful clues in the form of error messages or symptoms. Up until step #6, when you run commands to repair GRUB or install rEFInd on your hard disk, this process is relatively safe; booting rEFInd from a USB drive or CD-R is very unlikely to create new problems, since rEFInd run in this way won't write anything to the hard disk.

  • First of all thank you for your time. I did all the steps you mentioned above using refind-flashdrive-0.10.8.img. In the boot device menu in Bios I selected "UEFI USB Flash Drive" but nothing new happened. Same errors: "EFI USB Device boot failed." I am sure that there is no problem with the my flash drive and I have created the usb using dd. It doesn't seem to work. Do you have any more ideas about what can I do here? Thanks. – oodNinja Jun 18 '17 at 1:14
  • You might try using the firmware's option to reset all its options to their defaults. This is likely to wipe the existing boot loader entries, but as they don't seem to be working now, this doesn't seem like a great loss; and if it's successful, you should be able to use the rEFInd USB drive to get booting again. – Rod Smith Jun 18 '17 at 2:11
  • I tried default settings, default factory settings, default setup and nothing new happened. Any other solution? Is there a way access the storage of this laptop by any means by just going up to the bios? – oodNinja Jun 18 '17 at 3:42
  • You might check the manufacturer's site to see if there's a firmware update available. This is a long shot, but it's conceivable you're running into a bug that's fixed in a more recent release. – Rod Smith Jun 18 '17 at 13:09
  • I cloned my entire eMMC onto an HDD before installling ubuntu on my laptop. Do you think it is possible to boot from the HDD via a SATA-to-USB cable? (It is proper clone made using CloneZilla.) – oodNinja Jun 20 '17 at 3:54

Not the answer you're looking for? Browse other questions tagged or ask your own question.