I have an issue where the apt-get update command is not working correctly.

Eg below is part of the output of the command sudo apt-get update

Err:1 http://security.ubuntu.com/ubuntu xenial-security InRelease Could not resolve 'cusxwtc-mwg6'
Err:3 http://pkg.jenkins.io/debian-stable binary/ InRelease Could not resolve 'cusxwtc-mwg4'

I have tried the command host -v cy.archive.ubuntu.com and it verifies the domain name is resolved.

I have also noticed that in each failed repository retrieval i can see the Could not resolve 'cusxwtc-mwg4' which doesn't make any sense. I have tried searching for it but i get no results.

The same message is shown (Could not resolve 'cusxwtc-mwg4') if i also try to install anything using apt-get.

What does the cusxwtc-mwg4 or cusxwtc-mwg6 mean and how can this issue be resolved?

I am using a static address IP config during the above issue but the issue is fixed if i use a dhcp configuration. But uaing static address is a requirement for me.


This is related to McAfee Web Gateway installed in my organizations corp network.

I have overcome this issue by adding the following(replace domain with corps domain)

dns-search example.com

In the /etc/network/interfaces file

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.