0

Recently, I have dual booted Ubuntu on Windows 10 and now I tried to install numpy python module but is not getting installed.
It is showing the following errors when I type help("modules"), I can see that numpy is not installed.

Please help me in solving this problem.

d

harani@chikki:~$ python -m pip install numpy

Collecting numpy
  Downloading numpy-1.13.0-cp27-cp27mu-manylinux1_x86_64.whl (16.6MB)
    100% |████████████████████████████████| 16.6MB 52kB/s 
Installing collected packages: numpy
Exception:

Traceback (most recent call last):

  File "/usr/local/lib/python2.7/dist-packages/pip-9.0.1-py2.7.egg/pip/basecommand.py", line 215, in main
    status = self.run(options, args)

  File "/usr/local/lib/python2.7/dist-packages/pip-9.0.1-py2.7.egg/pip/commands/install.py", line 342, in run
    prefix=options.prefix_path,

  File "/usr/local/lib/python2.7/dist-packages/pip-9.0.1-py2.7.egg/pip/req/req_set.py", line 784, in install
    **kwargs
  File "/usr/local/lib/python2.7/dist-packages/pip-9.0.1-py2.7.egg/pip/req/req_install.py", line 851, in install
    self.move_wheel_files(self.source_dir, root=root, prefix=prefix)

  File "/usr/local/lib/python2.7/dist-packages/pip-9.0.1-py2.7.egg/pip/req/req_install.py", line 1064, in move_wheel_files
    isolated=self.isolated,

  File "/usr/local/lib/python2.7/dist-packages/pip-9.0.1-py2.7.egg/pip/wheel.py", line 345, in move_wheel_files
    clobber(source, lib_dir, True)

  File "/usr/local/lib/python2.7/dist-packages/pip-9.0.1-py2.7.egg/pip/wheel.py", line 316, in clobber
    ensure_dir(destdir)

  File "/usr/local/lib/python2.7/dist-packages/pip-9.0.1-py2.7.egg/pip/utils/__init__.py", line 83, in ensure_dir
    os.makedirs(path)

  File "/usr/lib/python2.7/os.py", line 157, in makedirs
    mkdir(name, mode)

OSError: [Errno 13] Permission denied: '/usr/local/lib/python2.7/dist-
packages/numpy-1.13.0.dist-info'
0
0

Maybe you have to try

pip install --user numpy

I am not sure and haven't done this before. I just show similar questions with python or other python based packages.

I don't think it will cause you any problem... just try!

2
  • Thank you.I tried sudo pip install numpy then numpy is successfully installed but it gave a message The directory '/home/dharani/.cache/pip/http' or its parent directory is not owned by the current user and the cache has been disabled. Please check the permissions and owner of that directory. If executing pip with sudo, you may want sudo's -H flag. The directory '/home/dharani/.cache/pip' or its parent directory is not owned by the current user and caching wheels has been disabled. check the permissions and owner of that directory. If executing pip with sudo, you may want sudo's -H flag. – dharani kaku Jun 17 '17 at 8:54
  • try sudo chown dharani:dharani /home/dharani/.cashe/pip sudo chown dharani:dharani /home/dharani/.cashe/pip/http and then again... May be better try sudo apt-get install python-numpy try the second and if fail the first – koleygr Jun 17 '17 at 9:19

Not the answer you're looking for? Browse other questions tagged or ask your own question.