0

Every time Issue the command nvidia-settings -I /usr/lib/libnvidia-gtk3.so.381.22 I get the following error:

ERROR: /usr/lib/x86_64-linux-gnu/libharfbuzz.so.0: undefined symbol:
       FT_Reference_Face


ERROR: A problem occured when loading the GUI library. Please check your
       installation and library path. You may need to specify this library when
       calling nvidia-settings. Please run `nvidia-settings --help` for usage
       information.

I have to point directly to the GTK lib because the package wants to look for a different one that does not exist.

This happened after I upgraded from 14.04 to 16.04.

Thanks for any help!

2
  • A simple online search leads me to believe that FT_Reference_Face is part of FreeType.
    – waltinator
    Jun 16, 2017 at 20:23
  • Thanks for the reply. I understand that it is and have searched as well. Would getting rid of libfreetype6 help? Don't a lot of other packages depend on freetype?
    – JustHeavy
    Jun 16, 2017 at 20:45

1 Answer 1

1

I fixed this by going here LINK

I then found the file named 'freetype-2.8.tar.gz' extracted it, and then I ran the command ./configure in that directory, and then ran make I received an error and had to modify the file to what the error suggests. You will see this when you ran the command. After correcting everything I ran the command sudo make install

After doing all of the above, nvidia-settings finally worked.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .