0

I am trying to repair a computer on which ubuntu and windows were installed. However it immediately boots into grub rescue with the message

error: no such device: <...>.
Entering rescue mode...
grub rescue> _

I also tried to boot from a live Ubuntu boot stick and a Windows boot stick, both do not work, it immediately enters the grub rescue menu again. I also tried some of the solutions suggested in the ubuntu forums with using ls and setting the root partition, but I constantly get the "unkown filesystem" error when using ls:

grub rescue> ls
(hd0) (hd0,msdos2) (hd0,msdos1)
grub rescue> ls (hd0)
error: unkown filesystem.
< same for the others >

Can anybody help me please?

5
  • Booting to a Ubuntu Live DVD/USB should work, and allow you to begin to troubleshoot your problem. Are you sure that you're actually booting from the USB, and not still booting to the hard disk? You should be using the BIOS boot, usually entered by F12, ESC, or DEL, depending on your computer. If you can get into the Live USB, you can use fsck or gparted to start troubleshooting.
    – heynnema
    Jun 16, 2017 at 15:02
  • Thank you for your comment. I tried every possible option available in the BIOS boot menu. However it still boots into grub rescue without starting from the boot stick.
    – phoebus
    Jun 16, 2017 at 15:40
  • Do you have access to a Live DVD?
    – heynnema
    Jun 16, 2017 at 15:42
  • unfortunately not ..
    – phoebus
    Jun 17, 2017 at 7:54
  • If you can't boot to a Ubuntu Live DVD/USB... you're kind of stuck between a rock and a broken computer.
    – heynnema
    Jun 17, 2017 at 12:49

0

You must log in to answer this question.

Browse other questions tagged .