5

Every time I want to export a file, gimp opens /tmp folder but I want to change this to ~/Downloads or any other folder.

How can I do this permanently?

Update:

Gimp seems to remember export folder for already exported files.

But when I use xfce4-screenshooter app to import the screenshot and then try to save it - the folder is set to /tmp.

Is there any way to point it to different folder in this case ?

I am not using any specific Desktop Environment - just i3 with a bunch of additional apps.

  • /tmp would be a really odd choice - it is supposed to use one of the XDG_* folders. Do you have set up some of the XDG_* environment variables to /tmp? – Michael Schumacher Jun 17 '17 at 20:09
  • @MichaelSchumacher You are right, gimp uses those Env variables. I have updated my question tho - my issue occurs only when I import image from xfce4-screenshooter. – Michal Przybylowicz Jun 26 '17 at 15:10
  • A useful approach might be to tell xfce4-screenshooter where to store the screenshots and avoid or at least soften this issue - see askubuntu.com/questions/252738/… – Michael Schumacher Jun 27 '17 at 13:49
2

There does not appear to be a direct method to do this with Gimp but there is an acceptable work-around that may be enough for you. Use the following 3 steps:

1. Export the Image. First use the 'Export Image' as usual:

enter image description here

2. Set your preferred location. Next navigate to your preferred location and then use the '+' key at the bottom left of the screen to set this location permanently in the Gimp preferences. In my example here I am using ~/test:

enter image description here

3. Export your next image. Next time you Export an image you will see your desired location in an easily accessible, single click location:

enter image description here

Not perhaps a perfect solution but this will hopefully fulfil your needs...

  • I am already using this solution but was wondering if there is a way to set the folder in gimp settings / configuration file maybe ? – Michal Przybylowicz Jun 17 '17 at 10:44
1

It seems that Gimp has no config for it an uses an operational system setting.

Take a look at this reply for the same question:

Priority of default paths for Export: 1. Last Export path; 2. Path of import source; 3. Path of XCF source; 4. Last path of any save to XCF; 5. Last Export path of any document; 6. The default path (usually the OS 'Documents' path).

I tested the Documents path (for KDE: System Settings > Applications > Locations) and it worked. My Gimp was using that setting.

I also tested changing the working directory, according this reference (for KDE: KDE Menu Editor > Advanced tab > Work path), but not changed the default save/export dir.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.