2

I'm trying to rename files using Nautilus but it's taking a lot of time

screenshot

Operation gets cancelled if I click on cancel. and for the duration of renaming which is generally around 30 secs I can't even open that file. it's really painful while renaming multiple files. It's just affecting Nautilus, mv is fine and it generally happens on the newly created files

What I've tried?

I've tried Reinstalling Nautilus

sudo apt-get install --reinstall nautilus

I think it solved the problem for some time, But I again encountered it today

I'm using Ubuntu Gnome 17.04 if that matters

9
  • 2
    Does it also take that long if you rename it from the terminal using mv or is it just Nautilus? It's probably also interesting on what kind of storage medium and file system the file is located.
    – Byte Commander
    Jun 15, 2017 at 16:51
  • @ByteCommander let me try with mv and storage is a 7200rpm Toshiba HDD and file system is Ext4 Jun 15, 2017 at 16:52
  • If you rename within the same partition, the operation should be 'lightning fast', if you rename alias move from one partition to another one, the file's content must be written to the new partition, which can take time. If it takes time within the same partition, I think there is some [unnecessary?] overhead task going on. I ask the same question as @ByteCommander: What happens if you rename with the mv command?
    – sudodus
    Jun 15, 2017 at 16:54
  • 2
    @sudodus sorry mv was instant, I messed up the command first time, mv is happening instantly, they are within the same directory (let alone partition) Jun 15, 2017 at 16:58
  • 1
    @sudodus definitely, I should just try to reinstall nautilus Jun 15, 2017 at 17:00

0

You must log in to answer this question.

Browse other questions tagged .