5

After perusing through several answers here and trying them out, I'm stumped as to what's causing the slow wifi on my laptop.

For reference, I tested the wifi on my laptop both in Windows 7 and in Ubuntu 16.04 LTS. I clocked an average down speed of ~28 Mbps on Windows and ~9 Mbps in Ubuntu.

I tried this Ask Ubuntu answer which brought my Ubuntu down speed to ~22 Mbps but my speeds go back down after the laptop comes back from sleep.

I used the wireless-info script to post my wifi information here.

Please let me know if there's any additional information needed and I'll get right on it. Thanks for your help.

  • 1
    Is Kiwi and Burr a router over which you have administrative privileges? As an experiment and to humor old Chili, please try changing the name to KiwiandBurr or some such without spaces. Reboot the router and the computer and tell us if there is any improvement. – chili555 Jun 15 '17 at 14:25
  • Removing spaces from the SSID didn't have an impact – Kashif Jun 16 '17 at 0:45
1
+50

I would change the channel the wifi router is on to channel 9, then I would disable wifi power management with

sudo sed -i 's/wifi.powersave = 3/wifi.powersave = 2/' /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf
systemctl restart network-manager.service

You may also benefit from enabling aggressive TX in the iwlwifi module with

sudo modprobe -r iwlwifi
sudo modprobe iwlwifi 11n_disable=8

If there is no improvement with that setting you can just reboot for it to return to the default setting

  • Of all the answers posted, this had the most effect. Not perfect but still an improvement. Thank you! – Kashif Jun 28 '17 at 22:25
0

I had same type of problem with ubuntu 16.04 in my HP laptop with realtek wireless card. I installed a repo made by a friend and it's working fine now. The repo link is :

https://github.com/roopansh/rtl8723be_wifi

0

Try creating shell script in /etc/pm called rm_precedence.sh with the following conent:

#!/bin/bash

case "$1" in
  hibernate|thaw|resume|suspend)
    sed -i '/^#.* precedence ::ffff:0:0/96 100 /s/^#//' /etc/gai.conf
    ;;
esac

And don´t forget to make it executable with sudo chmod +x rm_precedence.sh

I hope this helps you.

  • 1
    When posting a script you should provide a brief explanation of what it does and how. After which the reader should appreciate why it is necessary. – WinEunuuchs2Unix Jun 26 '17 at 2:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.