My Ubuntu Server 17 isn't connecting to my network (Ethernet).

I've tried restarting the network service but get an error telling me to run

journalctl1 -xe

which shows me the error

Error getting hardware address for enp3s0  
Failed to start Raise network address

this is my /etc/network/interfaces

source /etc/network/interfaces.d/*

auto lo
iface lo inet loopback

auto enp3s0
iface enp3s0 inet dhcp

I've searched all over but most people say to change the the interfaces to use eth0, and I've tried that but it didn't fix it at all so not sure what else to try

$ ifconfig

lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
  inet netmask
  inet6 ::1 prefixlen 128 scopeid 0x10<host>
  loop txqueuelen 1000 (Local Loopback)
  RX packets 352 bytes 26304 (26.3 KB)
  RX errors 0 dropped 0 overruns 0 frame 0
  TX packets 352 bytes 26304 (26.3 KB)
  TX errors 0 dropped 0 overruns 0 frame 0 collisions 0
  • Please edit your question to show the result of the command: ifconfig
    – chili555
    Jun 15, 2017 at 1:50
  • @chili555 done, sorry that took so long, cant ssh into it
    – Toxicable
    Jun 15, 2017 at 2:00
  • It seems you have no ethernet interface at all. Perhaps your hardware needs a driver. That's a whole different question.
    – chili555
    Jun 15, 2017 at 2:04
  • Im confused, it was working on this device literally last night and now all of a sudden it has no driver? Should I maybe just reinstall ubuntu?
    – Toxicable
    Jun 15, 2017 at 2:06
  • Try a live session and see if ethernet is there first.
    – chili555
    Jun 15, 2017 at 2:18

1 Answer 1


I was getting the same error for my interface labeled p5p1.

Running lshw -C network yielded output similar to the following (the interface works now so some details will be different):

       description: Ethernet interface
       product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: p4p1
       version: 06
       serial: 18:67:b0:df:4e:68
       size: 1Gbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=rtl8168e-3_0.0.4 03/27/12 ip= latency=0 link=yes multicast=yes port=MII speed=1Gbit/s
       resources: irq:27 ioport:e000(size=256) memory:f0004000-f0004fff memory:f0000000-f0003fff

The pertinent line is logical name: p4p1. Somehow networking was configured to bring up interface p5p1 but the os is recognizing the device as p4p1.

I updated /etc/network/interfaces to replace p5p1 to p4p1 then reset the networking services. The interface came up no problem.

  • Why did this answer get downvoted? I came across this question when searching for a similar problem and I thought I'd do the internet (and my future self) the favor of chronicling a solution that was simpler than "... reinstalling ubuntu."
    – brycemcd
    Mar 12, 2018 at 19:27

Not the answer you're looking for? Browse other questions tagged .