1

I have a dedicated server that sits at home and is not public, running Ubuntu server. I normally tested game servers and websites on it. One day I went onto putty, my ssh client, and for some reason had trouble signing in. Then I went to the server itself and hooked up a monitor and keyboard and tried signing in from there and still could not login.

I restarted the system many times and still had the same result. It says (access denied). But for whatever reason I can login using my root account. My root password is the same password I use for my normal account. So I know my password isn't incorrect. And I know my username is correct as well. I've signed into this server many times without a problem. I'm stuck and have no clue on why and how this is happening.

2
  • 2
    you can use passwd from the root account to reset your password Jun 15, 2017 at 0:21
  • 2
    Anyway you shouldn't have the same passwd for your root account ..
    – derHugo
    Jun 15, 2017 at 12:08

1 Answer 1

3

Passwords of other users are not available (easily) even to root. They are hashed in the /etc/passwd database and /etc/shadow as well.

Your best bet here is to reset the password of your user with passwd like Android Dev suggested in the comments:

sudo passwd <yourusername>

and follow the on-screen steps to set a new password.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.