5

For a particle physics project (micrOMEGAs), I have had to unpack a .tgz, and then run "make" in it (following this tutorial https://lapth.cnrs.fr/micromegas/).

I first unpacked using:

tar -zxvf micromegas_4.3.4.tgz

Then I obtained a folder micromegas_4.3.4, in which I ran make:

cd micromegas_4.3_4
make

At the end of the process, the terminal is available for next instructions, but in its last message mentions:

'../lib/micromegas.a' seems to have been created in deterministic mode. 
'limits.o' will always be updated. 
Please consider passing the U flag to ar to avoid the problem.

How do I fix this (supposedly using non-deterministic mode?)?

There are next steps to this installation process, but for the moment I just wanted to make sure that my folder micromegas_4.3.4 has been accurately compiled using make, and if not, what other packages/auxiliary files would I need to add to my Ubuntu platform.

Fundamentally, I am just compiling the contents of an unpacked folder. Then this is supposed to be ready to use using the command line (no GUI involved), for physical calculations.

(This is Ubuntu 17.04 running on a VirtualBox in Windows 10 by the way.)

  • Could you please add a little more detail? What exactly did you do, what did you want to achieve and what happened instead? Did you encounter any warning or error messages? Please reproduce them in their entirety in your question. You can select, copy and paste terminal content and most dialogue messages in Ubuntu. (see How do I ask a good question?) – David Foerster Jun 14 '17 at 21:52
  • I have expanded a bit on my post and its context, and provided the link to the specific setup I am supposed to follow, if that is of any help. – N.E. Jun 14 '17 at 23:19
3

The message from ar is a notice about the build process not an error message. As far as I understand it, it means that rebuilding the software after modification may take longer than necessary; nothing to worry about.

  • Understood. What about the deterministic mode? Is that a cause for concern? Because I do get problems in the ulterior parts to my coding (not mentioned in my original post) and was trying to rewind back to where I could have made any mistake(s). – N.E. Jun 15 '17 at 5:56
  • @N.E.: I suggest you look up "deterministic" in the ar(1) manual. – David Foerster Jun 15 '17 at 8:49
  • Apologies but I'm quite new to Ubuntu, and can't seem to figure out, in the manual you just showed me, where and if I can perform such a thing as pass the U flag to ar. – N.E. Jun 15 '17 at 12:08
  • Could you please open a new question if you have a new or follow-up question? The comment section is not suitable or meant for new questions or extended discussion. You’re welcome to send me a comment with a notification to draw my attention to it. Thanks. – David Foerster Jun 15 '17 at 16:54
1

The problem is due to change in the behavior of the ar command, which is now configured with --enable-deterministic-archives (see here and here).

A possible solution is to redefine the global variable for ar flags to disable deterministic archives with the U option. In the console before the make command, set

export ARFLAGS=rvU

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.