3

I have a dual boot Windows/Linux computer.

Following a distribution update, Ubuntu is totally unresponsive while windows works perfectly.

I think I had Ubuntu 14.04 (maybe 14.06).

I was asked if I wanted to update to 14.10.

It took a very long time to download and install all of the files. (My internet connection is very good.)

The computer restarted - after asking me if I wanted it to restart now.

When it booted back up, the log-in screen was unresponsive. I typed in my password and pressed enter - nothing happened. I used the mouse - nothing happened. I'm unable to log-in.

I've restarted and shut down several times. No joy.

Do I need to re-install Ubuntu? The only way I know if to make a Windows recovery USB, clear the Linux partition, boot from the recovery USB and "fix" to remove GRUB. Then install Ubuntu again.

4
  • 1
    What happens if you press CTRL+ALT+F1 while on the login screen? Also, does it boot in recovery mode (select recovery mode in GRUB)? Commented Jun 14, 2017 at 16:32
  • CTRL+ALT+F1 does not work. In GRUB I went through "advanced options for ubuntu" then into "ubuntu, with linux, ..., (recovery mode)". This worked. In recovery mode I went to "repair broken packages". That gave a terminal with very large writing that scrolled up quickly. At the end it asked me to agree to install/update things. I did that and was sent back to the menu. I chose "return to normal boot". All I got was a white line space cursor blinking in the top left of a black screen for as long as I waited. I tried to boot again after forced restart and got the same problem. Commented Jun 14, 2017 at 17:14
  • You didnt include many details. How much RAM do you have? Do you have access to a liveUSB? How big did you make the Ubuntu partition? Commented Jun 14, 2017 at 17:27
  • I have 4GB RAM. I have the live USB I used to install Ubuntu. I have over 130GB for the Ubuntu partition. Commented Jun 14, 2017 at 17:32

2 Answers 2

1

First thing to try before reinstall is to connect to the console to get access to the command line where you can check things like disk space, CPU usage, process running, etc.
If you don't know the cause of the problem the reinstallation may not work either.

Try:

  1. Press Ctrl + Alt + F1

  2. Log in. It's ok not to see the password you are typing in.

  3. Use ps or top command to check the process running, CPU usage, etc.

  4. Check the disk usage by typing the command dh -h and verify if you have enough space on the all partitions.

  5. In case of doubt when using any command you can always find more information typing
    man name_of_command to access the manual pages for the command you want to know more about.

4
  • CTRL+ALT+F1 does not work :-( Commented Jun 14, 2017 at 17:16
  • CTRL+ALT+DELETE? Try also F2, F3 Commented Jun 14, 2017 at 17:18
  • Ok, amd restarting... Commented Jun 14, 2017 at 17:19
  • CTRL+ALT+DELETE doesn't work, nor do any of the Function buttons, nor does CTRL+ALT+FX. I see the password screen with my screen saver, there is a Wifi pop-up, and the password cursor blinks. As soon as I press anything the password cursor freezes. There is an icon of a person with arms and legs out-stretched in a circle in the top right. Commented Jun 14, 2017 at 17:27
0

Boot to recovery mode: https://wiki.ubuntu.com/RecoveryMode

Then, open a root shell and see, if you ran out of disk space: df -h.

Also checking system logs might shed some light on the issue: less /var/log/syslog

Perhaps the update process did not finish successfully? dpkg --configure --pending will configure all packages that were extracted but not yet configured.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .