I use KDE plasma 5.10.1 .

I use Alt+1 ... Alt+10 to change tabs in web browsers or konsole .
my problem is Alt+1 not working in plasma desktop and i always replace /usr/bin/kglobalaccel5 to /usr/bin/kglobalaccel for fix this problem .

For a long time plasma 5 have this problem .
Why kglobalaccel5 can not handle Alt+1 ?
note : I dont use NumPad

2 Answers 2


There is a shortcut in System Setting/Shortcuts/Global Shortcuts for Walk Through Windows of Current Application (Reverse), which is set to alt+~, if you delete that shortcut (i.e. set it to custom and leave it empty, then press apply) you will be able to use alt+1 in other applications, like you case with the browser.

(Tested under different Linux distro with KDE Plasma.)

Edit: on my keyboard layout ~ is on key 1, maybe that is why it worked for me.

  • Worked for me. Although I had to disable "Walk through windows of current application" which was the back tick: Alt+` I was really annoying, thanks for the fix.
    – Rsh
    Aug 25, 2020 at 12:19

disabling Alt+` and Alt+~ shortcut will works but we will remove a good shortcut! the better way is to edit the "ir" keyboard layout manually and remove the accent from key 1.

Follow this steps:

  • sudo vi /usr/share/X11/xkb/symbols/ir
  • find a line containing this:
key <AE01> { [ Farsi_1,     exclam,              grave,                   1       ] };
  • remove "grave,". the new line should be:
key <AE01> { [ Farsi_1,     exclam,              1       ] };
  • save and exit
  • remove ir keyboard and add again
  • Finished!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.