3

I was originally having trouble with the MySQL server getting errors and I read a comment on a forum board saying that once they rebooted Ubuntu, the MySQL server started to work again. So I decided to do sudo reboot and I immediately got a message saying:

Connection to insert_ip_address closed by remote host.

I tried to ssh back into server and I got a

ssh: connect to host insert_ip_address port 22: Connection timed out

I thought to myself, maybe I have to wait for a couple of minutes for it to comeback on. Unfortunately, I have been trying to log back in for the past couple of hours and I still get the same message. I have this Ubuntu server from Digital Ocean. I know there is an option to power off or power cycle your server. I did both of these and I still cannot log back in.

2
  • Okay, I will edit it Jun 14, 2017 at 2:54
  • 2
    If the server isn't accessible remotely after reboot you need to reach out to someone with physical access to it, i. e. its hoster. This is unrelated to Ubuntu and off topic here. Jun 14, 2017 at 18:36

2 Answers 2

3

Digital Ocean is an ISP providing Internet access to servers. I gather you do not have physical access to the machine that is at the IP address you are trying to SSH into.

I am unable to ping the server. It apparently never came back up after you issued the reboot command, or it shut down and stayed powered off after you issued that command.

You'll need to contact the Digital Ocean Support guys and have them fire it back up for you.

As an aside, you should not resort to rebooting to solve problems before trying other solutions. A better method would be to stop and restart the service.

sudo service mysql stop

sudo service mysql start

or

sudo service mysql restart
2
  • 1
    Well, prior to being locked out of the server. I did do stop, start, restart. I tried to purge and reinstall mysql. And I would still have trouble getting mysql to work. I had a weird, but common error that stated that MySQL server cannot connect through a socket. I have tried many suggestions that were made to fix this error, but nothing worked. In any case, I will look into support so that I can get some help with this. Jun 14, 2017 at 2:54
  • If my answer solves your problem, as it should, you can mark it as a correct answer and that will take care of that. As for the original mysql problem, best to open a new question, providing as much information about the error(s) and steps you've taken so far to fix it. There are more than a few mysql wizards here. Someone should have the answer you need. The format of this site is to ask one question for each problem you are having. There's already a pretty big database of mysql problems and solutions here to research. Reboot, purge and reinstalling software barely scratches the surface
    – jones0610
    Jun 14, 2017 at 3:05
0

Digital Ocean has a web console you can use if the droplet is running.

Make sure it is powered up (in the DO Droplets view for the specific host).

Once powered-up, click Access, then the Launch Console button.

Make sure sshd is running.

Make sure no firewall is blocking your ssh port.

Then make sure MySQL is running

Then try sshing into your droplet.

5
  • I am having a hard time with their web console. I am trying to reboot it in order to get ssh up and running but I constantly get errors when it tries to reboot. I get errors like, error: file '/boot/ grub / i386-pc / ufs1-be.mod' not found or error: file '/boot/ grub / i386-pc/ udf.mod' not found. I don't know what to do at this moment right now Jun 14, 2017 at 17:53
  • @black_yurizan :: then it's time to blow it away and try over, so long as you don't have any data on it yet.
    – warren
    Jun 14, 2017 at 18:14
  • aww shit don't tell me that, I have months of web projects saved on that. If that is the only option I am going to be so pissed Jun 14, 2017 at 18:43
  • @black_yurizan - if you're getting errors about /boot/grub, udf.mod, etc - sounds like you have major issues with the OS. Do you have any backups from which you can recover?
    – warren
    Jun 14, 2017 at 18:46
  • @black_yurizan As stated previously, your question has been deemed off-topic. This thread seems to be devolving into a flame war. Of course none of this is helpful to your predicament. As I said in my answer, your best source of solution is probably with DO's support folks. Depending on their service model, they may do regular backups of user files. Or, they may leave that chore up to their customers. A call to them will probably get you back up and running quickly and if there is a way to recover any potentially lost or damaged files, they can probably help there as well. Best of luck!
    – jones0610
    Jun 14, 2017 at 19:31

Not the answer you're looking for? Browse other questions tagged or ask your own question.