1

First off I would like to begin with I am 100% new to Linux. With that being said I am not new to computers so I do have a fair amount of troubleshooting knowledge. I will try to give a short to the point description of what I have done.

  1. Created bootable flash drive using UUI and an iso from the official Ubuntu website
  2. Booted from the drive and activated the wifi through the additional drivers panel then tested wifi using firefox
  3. Installed Ubuntu without a problem and restarted laptop to boot from HDD
  4. Booted without issues but no wifi, opened the additional drivers panel to see the driver for wifi was turned off. Every time I click to use this driver and apply it hangs about 30% of the way through and will not continue. Laptop itself is not frozen as I can still do anything including cancel the installation.
  5. Reboot back into the flash drive and wifi starts working

I'm so confused lol...welcome to Linux :P

EDIT: The laptop is a Dell Inspiron 7347 with a i3-4010U and the wifi card is Dell Wireless DW1708 WLAN WiFi 802.11 b/g/n + Bluetooth 4.0 NGFF M.2 Card Part#: WC50G

01:00.0 Network controller [0280]: Broadcom Limited BCM43142 802.11b/g/n [14e4:4365] (rev 01) Subsystem: Dell BCM43142 802.11b/g/n [1028:0018] Kernel driver in use: wl Kernel modules: bcma, wl

0: hci0: Bluetooth Soft blocked: no Hard blocked: no 1: phy0: Wireless LAN Soft blocked: no Hard blocked: no 2: brcmwl-0: Wireless LAN Soft blocked: no Hard blocked: no

  • Please edit your question to add the result of the terminal command: lspci -nnk | grep 0280 -A3 Welcome to Ask Ubuntu. – chili555 Jun 14 '17 at 1:43
  • What is the exact response to the terminal command: sudo modprobe wl – chili555 Jun 14 '17 at 1:48
  • it output nothing – Brett Thomson Jun 14 '17 at 1:50
  • Please edit your question to add the result of: rfkill list all – chili555 Jun 14 '17 at 1:51
  • :-( Why do I always get the hard ones?? We'd like to see a full diagnostic work-up. Please download and run the script here: askubuntu.com/questions/425155/… Paste the result here and give us the link: paste.ubuntu.com – chili555 Jun 14 '17 at 2:04
0

We see this in your pastebin:

[ 1267.326870] ERROR @wl_notify_scan_status : 
[ 1267.326872] wlp1s0 Scan_results error (-22)
[ 3000.423902] ERROR @wl_dev_intvar_get : 

A Google search shows that it's a common error with no solid, sure fix suggested. Therefore, I suggest that we try some things to see if we can overcome it.

If your router is capable of N speeds, you may have better connectivity with a channel width of 20 MHz in the 2.4 GHz band instead of automatic 20/40 MHz, although it is likely to affect N speeds. I also have better luck with a fixed channel, either 1, 6 or 11, rather than automatic channel selection. In your case, your router is at channel 4 where there is considerable overlap; I suggest channel 11.

Also, be certain the router is not set to use N speeds only; auto B, G and N is preferred. After making these changes, reboot the router.

Next, I recommend that your regulatory domain be set explicitly. Check yours:

sudo iw reg get

If you get 00, that is a one-size-maybe-fits-all setting. Find yours here: http://en.wikipedia.org/wiki/ISO_3166-1_alpha-2 Then set it temporarily:

sudo iw reg set IS

Of course, substitute your country code if not Iceland. Set it permanently:

gksudo gedit /etc/default/crda

Use nano or kate or leafpad if you don't have the text editor gedit.

Change the last line to read:

REGDOMAIN=IS

Proofread carefully, save and close the text editor.

Next, I'd set IPv6 to Ignore in Network Manager: http://docs.fedoraproject.org/en-US/Fedora/18/html/Installation_Guide/images/netconfig/network-connections-ipv6-ignore.png This example is for ethernet, but you want wireless.

Finally, let's turn off power saving in Network Manager:

sudo sed -i 's/3/2/' /etc/NetworkManager/conf.d/*

Reboot the computer and let us hear your report.

  • got all of the settings changed and rebooted. doesn't appear to have changed anything, still can't activate the wifi driver – Brett Thomson Jun 14 '17 at 22:41

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.