1

I'm new to ubuntu, currently using ubuntu 17 and trying to run sudo apt --fix-broken install because i have this red error thing showing up close to my network indicator at the top saying

"An Error Occurred, please run package manager from the right-click menu or apt-get in the terminal to see whats wrong. The error message was: Error:brokenCount>0. This means that your your installed dependencies have unmet packages"

When i run sudo apt --fix-broken install. everything works cool in the beginning but somewhere along the line, i get this weired error..

Perl may be unconfigured (strict.pm did not return a true value at (eval 1) line 2.
BEGIN failed--compilation aborted at (eval 1) line 2. ) -- aborting
(Reading database ... 169172 files and directories currently installed
Preparing to unpack .../libc6_2.24-9ubuntu2_i386.deb ...
strict.pm did not return a true value at /usr/share/debconf/frontend line 5.
BEGIN failed--compilation aborted at /usr/share/debconf/frontend line 5.
dpkg: error processing archive /var/cache/apt/archives/libc6_2.24-9ubuntu2_i386.deb (--unpack):
subprocess new pre-installation script returned error exit status 5
Errors were encountered while processing:
/var/cache/apt/archives/libc6_2.24-9ubuntu2_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

I'm really stuck.. thanks in advance

Edited I get this error anytime i try to install any program..

You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
libbz2-1.0:i386 : Depends: libc6:i386 (>= 2.4) but it is not installed
libgcc1:i386 : Depends: libc6:i386 (>= 2.2.4) but it is not installed
libgpm2:i386 : Depends: libc6:i386 (>= 2.15) but it is not installed
libncurses5:i386 : Depends: libc6:i386 (>= 2.4) but it is not installed
libstdc++6:i386 : Depends: libc6:i386 (>= 2.18) but it is not installed
libtinfo5:i386 : Depends: libc6:i386 (>= 2.16) but it is not installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
  • sudo apt-get install libc6 should fix some if not all of your problems. – jones0610 Jun 14 '17 at 1:12
  • What version of Ubuntu are you using. Just saying 17 isn't enough. You have to say 17.04 or 17.10. – user689314 Jun 15 '17 at 17:51
  • Thanks for the help...17.04. but it was a new installation so i wiped the hard drive and reinstalled Ubuntu. everything is working now – Max Billionaire Jun 17 '17 at 13:56
0

This is an extremely common question. I've answered this for both steam and Google Chrome. Heres a modified version of my Google Chrome answer.

The first step to fixing this is to enable support for 32 bit binaries. You can do this by running

sudo dpkg --add-architecture i386 && sudo apt update Now try installing Google Chrome again.

If this still doesn't work, try installing the packages manually.

  1. Open up https://packages.ubuntu.com/ in your web browser.
  2. Scroll down to the Search package directories area.
  3. Select your version of Ubuntu from the Distribution drop down (You can find this by running lsb_release -a in the terminal. Use the codename section).
  4. Type in the package name and click search (In this case it's libgcc1)
  5. Click on the Exact Hit (In this case it's Package libgcc1)
  6. Select i386 in the table at the bottom
  7. Select one of the links on the page. It's probably a good idea to select the one for your country but it doesn't matter.
  8. Open up a terminal and navigate to the directory that you downloaded the package to.
  9. Run sudo dpkg -i file.deb, where file.deb is the file that you just downloaded. Once this is done, try to install Chrome again.

If it gives you the depends on error for a different package, just follow steps 1-9 for that package and try to install Chrome again. You may have to do this multiple times.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.