Facebook videos stopped playing but on youtube everything is still fine.

When I play videos on Facebook I get:

enter image description here

"Something Went Wrong, we're having trouble playing this video".

I already did:

1) Update

sudo apt-get update        # Fetches the list of available updates
sudo apt-get upgrade       # Strictly upgrades the current packages
sudo apt-get dist-upgrade  # Installs updates (new ones)

2) Restart PC

3) Tried chrome (everything working)

4) Click on Learn More - it says I should update and restart my browser.

5) Remove and install Firefox Web Browser and Adobe Flash Plugin from Sofware Center

6) Completely remove Firefox and Adobe Flash Plugin as recommended Here and here

As nothing has changed, what else should I try?

(Using Ubuntu 16.04)

  • What happens if you click Learn More? – You'reAGitForNotUsingGit Jun 13 '17 at 17:46
  • @AndroidDev it doesnt say the error, just say that I should restart browser and update it. Very generic. – Vitor Abella Jun 13 '17 at 17:49
  • Does it work in another browser? Like Chrome for example? – You'reAGitForNotUsingGit Jun 13 '17 at 17:51
  • @AndroidDev I dont have any other browser, but i can install chrome to test it. – Vitor Abella Jun 13 '17 at 17:55
  • @AndroidDev chrome is working fine – Vitor Abella Jun 13 '17 at 18:04

Installing ubuntu restricted extras solved this problem for me

sudo apt-get install ubuntu-restricted-extras
  • Prior to installing ubuntu-restricted-extras, did you have a Flash plugin installed, and if so which package was it? – Hee Jin May 10 '18 at 20:42
  • Yes I have installed adobe-flashplugin and also tried to update it. – vanillaSugar May 12 '18 at 10:52
  • OK! This is really useful to know. So when you installed ubuntu-restricted-extras, which installs flashplugin-installer, did it remove the adobe-flashplugin package? You can check with the command apt-cache policy adobe-flashplugin flashplugin-installer – Hee Jin May 13 '18 at 18:26
  • It seems that I have installed adobe-flashplugin package but not flashplugin-installer. pastebin.com/Z5JB1ywF – vanillaSugar May 14 '18 at 12:39
  • 1
    NOT installing adobe-flashplugin and applying this solution worked for me. – Pascal Jun 28 '19 at 15:46

I had the same problem. I fix it like this:

sudo apt-get install adobe-flashplugin

If that's already installed, try to upgrade it:

sudo apt-get upgrade adobe-flashplugin
  • you need to enable canonical partners in other softwares tab of software and updates software – Ramesh Maharjan Dec 2 '18 at 15:59

I have the same problem, and this solution works for me. You can find "Restart with Add-ones disable" in "Help" menu, the firefox will restart with safe mode, check the video works or not, then switch back to see how about it then.


Go to the Ubuntu Software Center and search for codecs and install the GStreamer Multimedia Codecs ( GStreamer OpenCV plugins ) it works for me.

  • GStreamer OpenCV plugins (gstreamer1.0-opencv) is not in the default Ubuntu 16.04 repositories, but it can be installed in Ubuntu 18.04 and later. – karel Jun 3 '18 at 0:14
  • 1
    Please provide a better answer than this. – Eranda Peiris Jun 3 '18 at 2:01

Not the answer you're looking for? Browse other questions tagged or ask your own question.