2

After deploying an Openstack cloud using juju/MaaS, I rebooted the controller by mistake. When it came back up, juju commands were hanging. I know I could delete

.local/share/juju/
.cache/juju/

And

juju add-cloud maas environments.yaml 
juju add-credential maas

And redeploy the cloud, but that doesn't sound like a production-ready system, to have to redeploy the cloud every time a node suffers a reboot.

Any suggestions? I tried backing up the contents of the above folders, re-adding the MAAS credentials and copying the YAML files back into the new cache files, but juju status hangs again. I'm guessing the SSH keys would have changed as well, after adding a new cloud.

1

This was because my reboot turned off the VMs (including my bootstrap node) hosted by the controller. Upon manually turning on the VMs, juju commands worked normally.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.