1

I just installed Ubuntu 14.04 on my new computer.

As soon as it was done, I installed gnome3 with:

apt-get install gdm3
apt-get install gnome-session-flashback

I currently work with two monitors: 1 DVI and 1 VGA.

Everything works fine if ONLY the DVI is plugged in.

However, if I plug my second monitor (VGA) before starting the computer, gnome doesn't work anymore; I can only see the background on the login screen, and the same after login (I blindly type my password and press enter).

If I move the mouse to the top left corner, the brightness lowers just like if I opened the menu, except I can't see it.

Second strange thing is, it works perfectly if I plug the VGA AFTER the startup.

Could anyone help me with this?

Hardware:

  • CPU: Intel i5 7400
  • MOBO: Asus Prime B250M-K
  • Graphics: Intel HD Graphics 630

1 Answer 1

1

I had the same problem, with the same motherboard (Asus Prime B250M-Plus). I tried to run Ubuntu 16.04 LTS (Gnome), Ubuntu-Mate 16.04 LTS (MATE) and Xubuntu 16.04 LTS (xfce), and had the same issue with all.

This only happens when the VGA is plugged. Apparently the motherboard creates a ghost monitor (which is named Laptop eDP-1) as primary monitor, and the real one monitor is set as secondary.
All the Menus and other things are invisible in the primary monitor, while the secondary monitor has only the background picture.

This problem doesn't exist when only HDMI is plugged in.

To get around it you can press Ctrl+Alt+T when you see the mouse pointer to open the terminal in your real monitor, and type:

mate-display-properties

to open Display Preferences. There you can disable the ghost monitor.

In GNOME use gnome-control-center display.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .