I installed Imagemagick and noticed that now my pdf files show that as the default application to open them. Tried to change that in properties but it would not take it. Removed Imagemagick in ubuntu-software but checking "properties" still shows Imagemagick as the default app to open for that pdf file. and it does not change when I select document viewer as the default app. Tried a reboot (several times) and each time ubuntu-software shows Imagemagick as "installed software" I remove it and it shows removed but is right back on the next re-start

The steps I took are as follows I opened "UBUNTU Software" clicked on the "Installed" drop down, Scrolled down to "Imagemagick" and clicked on "Remove". A small "1" then appeared next to "Installed" momentarily, it disappeared and the entry for "ImagMagick" also disappeared as there were two entries for "ImageMagick" I did this twice.

$ dpkg -l | grep imagemagick
ii  imagemagick                                 8:                          amd64        image manipulation programs -- binaries
ii  imagemagick-6.q16                           8:                          amd64        image manipulation programs -- quantum depth Q16
ii  imagemagick-common                          8:                          all          image manipulation programs -- infrastructure
  • Could you please specify in your question the exact steps you took to remove imagemagick? Also please include the output of dpkg -l | grep imagemagick after having removed the package.
    – b_laoshi
    Jun 12, 2017 at 6:41
  • I opened "Ubuntu Software" clicked on the "Installed" Drop down scrolled down to Imagemagick and clicked "Remove" a little "1" appeared next to "Installed" momentarily and then the entry disappeared did this twice as there were two instances of Imagemagick the out put from dpkg -1 | follows
    – J Strachan
    Jun 13, 2017 at 15:18

2 Answers 2


Try typing sudo apt remove imagemagick*. This will remove it through command line(you need to open terminal using Ctrl+Alt+T. If this doesn't work, it means that some other package on the system depends on ImageMagick and requires that package to operate correctly. You could try sudo apt-cache rdepends imagemagick* to find out which packages depend on imagemagick and which are preventing it from getting uninstalled.


The ii in front of each of the lines from your dpkg -l command indicates that the packages are indeed installed. For whatever reason, it would appear that the Software Center is not removing the imagemagick package.

From a terminal, try running

sudo apt-get purge -y imagemagick
sudo apt-get -y autoremove

The first command will either remove imagemagick or throw error messages. If it throws error messages, add those to your question.
The second command will remove any additional dependencies that were downloaded for imagemagick that are no longer required for any other packages installed on your system.

If you want to verify that the packages were removed, run dpkg -l | grep imagemagick again. If the packages were removed, you should not see any output.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .