So when I updated to Ubuntu 17.04 I opted for GNOME flavor since we all know we'll be using it by 18.04 anyway. But oddly my superkey is no longer functional. It worked fine in 16.10 default Ubuntu, and works fine in Windows. If I check inputs under Region and Language and click the little keyboard icon, all of my keys seem to function fine except both super keys. Also the | key is in the wrong location, but at least it works. I am using English (US) which is what I've always used in the past, and I did try other layouts just to be sure, such as English (UK). Again, all the keys worked except super. I'm using a Logitech G710 gaming keyboard, but again, worked in 16.10 Unity. Any ideas?


3 Answers 3


Use the Gnome Tweak Tool, and set "Icons on Desktop" to ON. Believe it or not, that will fix your super key.

Reference: Unity problems after installing GNOME desktop (ubuntu-gnome-desktop)

  • Sorry, but no luck. I think their problem was was having both DEs installed and them interfering. Mine is straight GNOME. Whatever the case may be, turning the desktop on in tweak does not fix the issue. And the key is still unresponsive in the keyboard view. Thanks for the suggestion though.
    – Eragon615
    Jun 12, 2017 at 15:26
  • @Eragon615 Sorry that didn't fix it. What do you mean "in the keyboard view"? Do you have any extra GNOME extensions installed?
    – heynnema
    Jun 12, 2017 at 15:28
  • Under Region and Language, Input Source, if you click the icon that looks like a keyboard it pulls up a window that looks a bit like an on screen keyboard. Pressing a key causes it to light up on the window, presumably for testing input. I've been using it as a kind of litmus test. All of my other keys function normally, superkey does not.
    – Eragon615
    Jun 13, 2017 at 5:59
  • @Eragon615 OK. My machine doesn't light up the super key on the on-screen keyboard, but it does activate the gnome overview mode, as it should. So don't look for the illumination.
    – heynnema
    Jun 13, 2017 at 13:05
  • Well, unfortunately it's not activating overview mode for me. I did set Print Screen to super, I forget how. I'm currently using it for the keyboard shortcuts that need super. Hopefully next version will fix whatever I broke.
    – Eragon615
    Jun 13, 2017 at 14:33

Use the Gnome Tweaks tool. Under the Keyboard & Mouse tab, select Additional Layout Options.Expand Alt/Win key behaviour and select disabled.



I had the same problem with a "Mad Catz v.7 keyboard" and I solved it by disabling the extra gamer keys by pushing the Mad Catz Logo key. I hope it will help someone.

  • That works! I have a Logitech G710+. It was demonstrating the same problem. I toggled off the little joystick key, and now the meta/windows keys work again. Thanks!
    – Gopherkhan
    Jul 17, 2019 at 21:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .