0

I have a dual boot system. Windows 8.1 and Linux Ubuntu 16.04 on separate drives.

In my Windows system, i hit the super key and search for something that i want to find. I couldn't be happier with Windows search especially if i properly enable the indexing capabilities.

Now Linux isn't that good i'm afraid, or i haven't unlocked all its potential. When i'm working with Linux i often (or always) mount the Windows drive as well in order to gain access to all my files. I usually keep all my files into the Windows system and i prefer a common place where i can store all my material which isn't OS specific. Since i have worked with Windows much more than with Linux i keep them there.

Now when i hit the super key on Linux and search for something it lists every file on the system, like Windows. But it doesn't display Windows files! Something like that is understandable with Windows, since it doesn't recognize the ext4 file system of Linux. However Linux recognizes Windows ntfs so it should be able to list them.

For example, I have created a few junctions on various Linux folders that point to corresponding Windows Folders on the other drive. For example on linux->Pictures i have a link that points to Pictures on my Windows drive and user directory, same with Music, same with Documents and Videos and Downloads (that's pretty much it).

What i want is when i search for something in Ubuntu to list all files in my Windows drive too. Why isn't that happening? Should i enable something somewhere in order for Linux to index those Windows files as well (not system files, just regular documents, ebooks, music, videos etc, etc)? Will anything happen with those files? Is that even possible? Are there any risks? I perform searches often and this possibility would be very desirable for me.

Thanks in advance.

1

This answer does not address your specific question, but deals with another problem that you may run into.

It's not a good idea to mount your Windows C: drive in Ubuntu and read/write files to its NTFS partition. Better to create a separate NTFS partition that can be shared between Windows and Ubuntu.

However, if you insist on mounting the C: drive, you should do the following...

In Windows...

  • boot into Windows
  • open the Power control panel
  • choose change what the power buttons do
  • choose change options that are unavailable
  • uncheck fast startup
  • close the Power control panel
  • open an administrative command prompt window
  • type powercfg /h off
  • Well, you don't mention the reason to do that. Can you please elaborate? Thanks. Actually you can look at the comment i posted a few hours ago to that response and tell me if it's related? – Nikos Jun 12 '17 at 20:32
  • When Windows shuts down, it saves the state of the machine and the file system, so it can start faster the next time. If you mount your C: drive and r/w to/from the NTFS file system, you circumvent the known/saved state, and you'll end up either corrupting it, or losing files. The two mods eliminate fast startup and the hibernation file. – heynnema Jun 12 '17 at 20:40
  • I have disabled hibernation a long time ago. It's negatives far outweigh the advantages imo. Ok i will do that. I don't remember having fast startup. Look at my comment in the answer below. Do you think there is any relevance with what happened? Thanks anyway. – Nikos Jun 12 '17 at 20:45
  • Since I don't know how/where you remounted your Windows drive to allow indexing, I can't say. But I doubt it had anything to do with your Ubuntu problem... although the timing sure is suspect. – heynnema Jun 12 '17 at 20:52
1

The case is that your Windows drive is not indexed by default. Probably because you mount it under /media directory which is not indexed on purpose. Answer to this question will tell you how to enable it. Though I'd rather mount the drive under different directory instead.

  • Thanks for responding. Why mount it under different directory and how to do it? – Nikos Jun 11 '17 at 23:54
  • 1
    locate is a shell utility for file search. It uses a database created with updatedb command. As described in the linked answer, the index database is used by unity dash as well. By default it doesn't index /media directory. I suggested to change the mount point, because media is usually used for all the temporary stuff, like thumb drives, sd cards, etc. so there's no point in indexing them. – michal Jun 13 '17 at 0:54
  • I can't think of anything that could go wrong with updatedb. Any chance you run out of free space on /, /home or /var? – michal Jun 13 '17 at 1:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.