0

I am simply trying to install a single boot system with Ubuntu 16.04 LTS on my old MacBook Pro 4,1. (Also tried 17.04 but I get an error that APT not working)

There are a few issues but the one that seems to be the most problematic is that the Grub does not install correctly.

I have tried doing the regular install on the drive and letting Ubuntu installer create the partitions etc. Much like the accepted answer here... EFI boot Ubuntu 14.04 on a Mac without rEFInd And that did not work.

I tried creating my own partitions much like this 16.04 new installation gives grub-efi-amd64-signed failed installation /target/ ubuntu 16.04 at the end and here https://help.ubuntu.com/community/UEFI#Creating_an_EFI_System_Partition

What I did was with Gparted on the try ubuntu I formated to drive to the following

fat32 size 250mb flags boot, esp

ext4 size 10000mb

linux-swap 4096mb

ext4 size 200gb

And then specifying in the installation process that the fat32 is an efi partition the ext4 is / and the second ext4 is /home

Set the boot installation location to the EFI

and I get this error: grub-efi-amd64-signed failed installation /target/ and then crashes the installer.

I am connected to the network, I have chosen to install 3rd Party Software and Update the ubuntu during the install.

I have also tried to setup the drive partitions alone in the ubuntu installer and same results.

What am I doing wrong?

EDIT:

Okay so I was able to install 17.04 following these instructions which solved the CD error... https://forum.kodi.tv/showthread.php?tid=126351

but now I am stuck at the following /dev/sda2: clean, 222460/14622720 files, 3071159/58476288 blocks

I tried nomodeset just like I had to to get the usb ubuntu to work, but it did not fix it. Any ideas?

EDIT 2: Reinstalled again, and updated everything this time around. Still nothing. Also tried to boot into GFX Safe Mode and Also nothing beisdes a blinking cursor

EDIT 3

I was able to get in. I followed this post, Blank screen Ubuntu 15.04 update with NVIDIA driver (nomodeset does not work), but when I reinstalled the nvidia drivers it stopped working again. And that does not seem ideal to run without the GFX Card. So is there something wrong with the NVidia-340 driver?

0

When single-booting Ubuntu on an Intel-based Mac, my recommendation is to treat it as if it were an old BIOS-based PC, not an EFI/UEFI-based PC. To do so, you must figure out how to boot the installation medium in BIOS/CSM/legacy mode. When so booted, if you drop to a shell, you will not see a directory called /sys/firmware/efi; if that directory is present, you've booted in EFI mode. When you install in BIOS/CSM/legacy mode, the Ubuntu installer should set up MBR partitions and install a BIOS-mode boot loader, rather than the EFI-mode boot loader that it's trying to install now. Thereafter, when the computer boots, the presence of MBR partitions will activate the firmware's CSM, and the firmware will try to boot in BIOS mode when it fails to find an EFI-mode boot loader.

That said, if you want to persist in an attempt to install in EFI mode, I've recently seen an uptick in problem reports similar to yours. There seem to be a variety of causes and solutions, although difficulty accessing the ESP seems to be a common thread. It's unclear what your cause is, but you might want to check out:

You might also want to try my rEFInd boot manager, either as a temporary way to boot your installation to fix it or as a replacement for GRUB. You can get CD-R or USB flash drive images of rEFInd on its downloads page and use the medium you create with that to boot your computer. Once you've booted Ubuntu, you can either try to install GRUB manually or install rEFInd to the hard disk using the PPA or Debian package version.

1
  • I was going to try the BIOS Boot method but I cannot seem to find out how to do that – Chris James Champeau Jun 12 '17 at 0:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.