1

This question already has an answer here:

I have been trying to figure out what is going on when I run apt-get update. I've tried going through the sources file and also using the Ubuntu Tweak to clean the sources list, but nothing is working.

When I run apt-get update I get this:

Reading package lists... Done
N: Skipping acquire of configured file 'main/binary-i386/Packages' as repository 'https://packages.microsoft.com/repos/vscode stable InRelease' doesn't support architecture 'i386'
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://download.opensuse.org/repositories/home:/Horst3180/xUbuntu_16.04  Release: The following signatures were invalid: KEYEXPIRED 1496576244
W: The repository 'http://ppa.launchpad.net/tualatrix/ppa/ubuntu xenial Release' does not have a Release file.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
W: Failed to fetch http://download.opensuse.org/repositories/home:/Horst3180/xUbuntu_16.04/Release.gpg  The following signatures were invalid: KEYEXPIRED 1496576244
E: Failed to fetch http://ppa.launchpad.net/tualatrix/ppa/ubuntu/dists/xenial/main/binary-amd64/Packages  404  Not Found
W: Some index files failed to download. They have been ignored, or old ones used instead.
W: Duplicate sources.list entry http://packages.microsoft.com/repos/vscode stable Release

marked as duplicate by karel, Zanna, Ravexina, user364819, Eric Carvalho Jun 11 '17 at 19:43

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

0

You are trying to install (or update) the package called Ubuntu Tweak from the PPA called tualatrix/ppa which is described on this page: https://launchpad.net/~tualatrix/+archive/ubuntu/ppa. However, this PPA does not contain any package that is compatible with your Ubuntu release (xenial) as it stopped being supported after trusty.

You could try to download the deb file for trusty and install that, but chances are the dependencies can not be fulfilled.

This article explains in more detail what has happened, and advises you to install Unity tweak instead.

To clean this up, delete the lines containing tualatrix from your sources.list file and/or delete any files containing tualatrix from sources.list.d. Alternatively, install ppa-purge and do sudo ppa-purge tualatrix/ppa.

Finally, run sudo apt update && sudo apt upgrade again.

Not the answer you're looking for? Browse other questions tagged or ask your own question.