2

I was trying to install google chrome but while installing getting the following messages. When I wrote

sudo dpkg -i ~/Downloads/google-chrome-stable_current_amd64.deb

I get the following messages:

Selecting previously unselected package google-chrome-stable.
(Reading database ... 237226 files and directories currently installed.)
Preparing to unpack google-chrome-stable_current_amd64.deb ...
Unpacking google-chrome-stable (59.0.3071.86-1) ...
dpkg: dependency problems prevent configuration of google-chrome-stable:
 google-chrome-stable depends on libappindicator1; however:
  Package libappindicator1 is not installed.

dpkg: error processing package google-chrome-stable (--install):
 dependency problems - leaving unconfigured
Processing triggers for bamfdaemon (0.5.3+17.04.20170406-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for gnome-menus (3.13.3-6ubuntu5) ...
Processing triggers for desktop-file-utils (0.23-1ubuntu2) ...
Processing triggers for mime-support (3.60ubuntu1) ...
Processing triggers for man-db (2.7.6.1-2) ...
Errors were encountered while processing:
 google-chrome-stable

And for

sudo apt-get install -f

I am getting the following messages:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following additional packages will be installed:
  libappindicator1 libindicator7
The following NEW packages will be installed:
  libappindicator1 libindicator7
0 upgraded, 2 newly installed, 0 to remove and 3 not upgraded.
9 not fully installed or removed.
Need to get 41.0 kB/89.1 kB of archives.
After this operation, 157 kB of additional disk space will be used.
Do you want to continue? [Y/n] Y
Get:1 http://bd.archive.ubuntu.com/ubuntu zesty/main amd64 libindicator7 amd64 16.10.0+16.10.20160913-0ubuntu1 [21.9 kB]
Get:2 http://bd.archive.ubuntu.com/ubuntu zesty/main amd64 libappindicator1 amd64 12.10.1+17.04.20170215-0ubuntu1 [19.2 kB]
Fetched 41.0 kB in 1s (40.5 kB/s)           
Selecting previously unselected package libindicator7.
(Reading database ... 237329 files and directories currently installed.)
Preparing to unpack .../libindicator7_16.10.0+16.10.20160913-0ubuntu1_amd64.deb ...
Unpacking libindicator7 (16.10.0+16.10.20160913-0ubuntu1) ...
Selecting previously unselected package libappindicator1.
Preparing to unpack .../libappindicator1_12.10.1+17.04.20170215-0ubuntu1_amd64.deb ...
Unpacking libappindicator1 (12.10.1+17.04.20170215-0ubuntu1) ...
Setting up libindicator7 (16.10.0+16.10.20160913-0ubuntu1) ...
dpkg: dependency problems prevent configuration of libc6:i386:
 libc6:i386 depends on libgcc1; however:
  Package libgcc1:i386 is not installed.

dpkg: error processing package libc6:i386 (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
dpkg: dependency problems prevent configuration of libpcre3:i386:
 libpcre3:i386 depends on libc6 (>= 2.4); however:
  Package libc6:i386 is not configured yet.

dpkg: error processing package libpcre3:i386 (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
dpkg: dependency problems prevent configuration of libgpg-error0:i386:
 libgpg-error0:i386 depends on libc6 (>= 2.15); however:
  Package libc6:i386 is not configured yet.

dpkg: error processing package libgpg-error0:i386 (--configure):
 dependency problems - leaving unconfigured
Setting up libappindicator1 (12.10.1+17.04.20170215-0ubuntu1) ...
No apport report written because the error message indicates its a followup error from a previous failure.
Processing triggers for libc-bin (2.24-9ubuntu2) ...
/sbin/ldconfig.real: /usr/lib/nvidia-375/libEGL.so.1 is not a symbolic link

/sbin/ldconfig.real: /usr/lib32/nvidia-375/libEGL.so.1 is not a symbolic link

dpkg: dependency problems prevent configuration of libselinux1:i386:
 libselinux1:i386 depends on libc6 (>= 2.8); however:
  Package libc6:i386 is not configured yet.
 libselinux1:i386 depends on libpcre3; however:
  Package libpcre3:i386 is not configured yet.

dpkg: error processing package libselinux1:i386 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
Setting up google-chrome-stable (59.0.3071.86-1) ...
update-alternatives: using /usr/bin/google-chrome-stable to provide /usr/bin/x-www-browser (x-www-browser) in auto mode
update-alternatives: using /usr/bin/google-chrome-stable to provide /usr/bin/gnome-www-browser (gnome-www-browser) in auto mode
update-alternatives: using /usr/bin/google-chrome-stable to provide /usr/bin/google-chrome (google-chrome) in auto mode
dpkg: dependency problems prevent configuration of liblzma5:i386:
 liblzma5:i386 depends on libc6 (>= 2.17); however:
  Package libc6:i386 is not configured yet.

dpkg: error processing package liblzma5:i386 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of liblz4-1:i386:
 liblz4-1:i386 depends on libc6 (>= 2.4); however:
  Package libc6:i386 is not configured yet.

dpkg: error processing package liblz4-1:i386 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of libgcrypt20:i386:
 libgcrypt20:i386 depends on libc6 (>= 2.15); however:
  Package libc6:i386 is not configured yet.
 libgcrypt20:i386 depends on libgpg-error0 (>= 1.14); however:
  Package libgpg-error0:i386 is not configured yet.

dpkg: error processing package libgcrypt20:i386 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
Errors were encountered while processing:
 libc6:i386
 libpcre3:i386
 libgpg-error0:i386
 libselinux1:i386
 liblzma5:i386
 liblz4-1:i386
 libgcrypt20:i386
E: Sub-process /usr/bin/dpkg returned an error code (1)
4
  • I have edited my questions for better clarifications. Thanks David Foerster. Commented Jun 15, 2017 at 14:05
  • Could you please edit your question to include the output of sudo apt-get install -f libgcc1:i386? Thanks. Commented Jun 15, 2017 at 16:58
  • What version of ubuntu are you using?
    – user689314
    Commented Jun 15, 2017 at 17:39
  • I am using ubuntu 17.04 @yamboy1 .. Commented Jun 16, 2017 at 14:07

2 Answers 2

3

It sounds like a dependency is not installed. I would do the following.

  1. Go to the terminal

  2. Type

    sudo dpkg -i /path/to/deb/file
    

    example for me it was:

    sudo dpkg -i /Downloads/google-chrome-stable_current_amd64.deb
    
  3. Then type

    sudo apt-get install -f
    

    sudo apt-get install -f will install any dependencies needed.

This is what I had to do to install Chrome on Ubuntu Gnome 17.04. I hope this helps.

4
  • 1
    Thank you to Zanna and David Foster for editing my response. I will do a better job with formatting in the future!
    – Mark Lines
    Commented Jun 13, 2017 at 3:54
  • The OP already tried sudo apt-get install -f, and it didn't work.
    – user689314
    Commented Jun 15, 2017 at 17:38
  • @MarkLines, Thanks for your efforts. I didn't clear my question back then. I tried to follow your instructions but the problem still remained. According to your instructions, I modified my question. Then I got solution from yamboy1 and my problem is solved as well. Thanks again. Commented Jun 16, 2017 at 14:19
  • @Adnatull Al Masum, No problem. I am glad that yamboy1 was able to solve your problem. That is what is important.
    – Mark Lines
    Commented Jun 16, 2017 at 18:22
0

I answered this same question about steam here. Heres a modified version for Google Chrome

The first step to fixing this is to enable support for 32 bit binaries. You can do this by running

sudo dpkg --add-architecture i386 && sudo apt update Now try installing Google Chrome again.

If this still doesn't work, try installing the packages manually.

  1. Open up https://packages.ubuntu.com/ in your web browser.
  2. Scroll down to the Search package directories area.
  3. Select your version of Ubuntu from the Distribution drop down (In this case it's yakkety).
  4. Type in the package name and click search (In this case it's libgcc1)
  5. Click on the Exact Hit (In this case it's Package libgcc1)
  6. Select i386 in the table at the bottom
  7. Select one of the links on the page. It's probably a good idea to select the one for your country but it doesn't matter.
  8. Open up a terminal and navigate to the directory that you downloaded the package to.
  9. Run sudo dpkg -i file.deb, where file.deb is the file that you just downloaded. Once this is done, try to install Chrome again.

If it gives you the depends on error for a different package, just follow steps 1-9 for that package and try to install Chrome again. You may have to do this multiple times.

2
  • Thanks @yamboy1. Finally I have installed chrome. But some doubts left in mind, I downloaded 64 bit binary of google chrome and my OS is 64bit as well. Why do I need to enable 32 bit binary? Commented Jun 16, 2017 at 14:14
  • Do you see all of the :i386 on the ends of some of the packages. This means that it is a 32 bit package
    – user689314
    Commented Jun 16, 2017 at 17:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .