1

I've got Ubuntu webserver set up in my place. Purchased domain and registered dynamic dns service on no-ip.com to take care of constantly changing external ip address. The thing is when I try to view my website outside of my network, meaning, I switch the wifi in my phone off and use data plan my phone came with I can't access it. It just keep struggling to connect and eventually get an error.

The way I went about it: I set my domain to forward all requests to the dns provider that manages changing ip address. So everytime when the ip change, dns service picks up on that and redirects all requests to the changed ip address. That's how I understand this works.

What am I missing here ?

Before you ask, yes, I could simply upload my files to the hosting website to take care of the hosting, but I like the idea of hosting my website on my own.

  • Public ip, i guess, is on ypur router wan interface? If yes you must do port forwarding on you router. From wan port to ip address of your server. Port is 80 or if you use https, port is 443. – 2707974 Jun 11 '17 at 8:35
  • Yeah I forgot to mention that. Port forwarding on my router is already set up. That's actually first thing I did. Using port 80. – Mark Alexa Jun 11 '17 at 9:08
1

Look for the DDNS settings in your router. When enabling it, you'll have the option of logging into your DDNS provider. It will automatically update the IP configuration with your DDNS provider when your IP changes.

This is usually found as a page in your Security settings somewhere close to where you configure your port forwarding settings.

  • Yes, that's one way to go but how's that different from what I did with no-ip.com which manages the ip changes for me ? The problem is that I can't view my website outside of my network. – Mark Alexa Jun 11 '17 at 10:13
  • It's not difference. It's a significant part of the process. Once you subscribe to the no-ip DDNS service you need a way to populate the new IP into the configuration. Your router provides a way to have this update automatic. – L. D. James Jun 11 '17 at 10:17
1

Okay so after googling for an hour or so I realised I'm a dummy ! LOL I've got everything set correctly apart from having domain forwarding all page requests to the correct IP ! I had it forwarding to private IP not the public one ! Like I said .... dummy.

  • By your comment to my answer, you didn't realize the important part of making the entry into the DDNS configuration of your router. – L. D. James Jun 11 '17 at 12:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.