It used to be possible to find it in either Tools > Options > Advanced > General > Config Editor or Preferences > Advanced > General > Config Editor.

How can I open it now?

  • Tools:

    enter image description here

  • Preferences:

    Thunderbird Preferences without Config Editor

For me there is a "Config Editor..." button in the Preferences window if I select "Advanced" (on TB 52.1.1).

Edit:

The "Advanced" tab has four sub tabs:

  • General
  • Data Choices
  • Network & Disk Space
  • Certificates

In the screenshot above you have the "Certificates" sub tab open. Click "General", and you'll hopefully see the "Config Editor..." button.

  • 1
    Looks like the OP is missing the tabs in the Advanced-section, the screenshot shows only the contents of the Certificates-tab, but there should appear several tabs in the Advanced-section, the button for the config-editor is in the General-tab in the Advanced-section. – mook765 Jun 11 '17 at 1:57
  • Thanks for the explanation, @mook765. I just edited my answer. (There is something wrong with the UI, so it's currently not obvious that those tab labels are clickable.) – Gunnar Hjalmarsson Jun 11 '17 at 2:11
  • 1
    I'm afraid that will not help as the sub-tabs to choose are not displayed. I think the OP has a corrupted profile and should backup his profile-folder and create a fresh profile. Probably the problem occurred due to changes in the config-editor. BTW, we can edit the config-file with a text editor, the file to edit is ~.thunderbird/<your_profile>/prefs.js, Thunderbird should not run while doing that. We can find out the location of the profile with Help > Troubleshooting Information. – mook765 Jun 11 '17 at 2:26
  • @mook765: Actually the sub-tabs are displayed just as well (or just as bad) in the OP's screenshot as they are for me. It's the first line below the icons. So there probably is some kind of bug, but even if it's not obvious, the labels are clickable. – Gunnar Hjalmarsson Jun 11 '17 at 2:53
  • 1
    You are right, know I see them too, they just don't look like tabs... – mook765 Jun 11 '17 at 3:35
up vote 2 down vote accepted

Turn off your Thunderbird and open ~/.thunderbird/<your_profile>/prefs.js.

Look for

user_pref("mail.preferences.advanced.selectedTabIndex", 3);

and delete it (or set it to 0 which is the default value).

Generally, look for preferences in prefs.js and find out which line is the culprit.


Thanks to mook765.

  • 1
    Look's like setting the value to 0 should do it. I think this setting is used to remember the last opened sub-tab in the Advanced-tab, so setting the value to 0 should open the sub-tab which holds the config editor-button... – mook765 Jun 14 '17 at 12:08

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.