9

Trying to figure out what this means:

enter image description here

I got into the GRUB menu, chose Advanced Options, boot in recovery mode, login as root, and I did:

root@xps:~# sudo fsck -f /
fsck from util-linux 2.27.1
e2fsck 1.42.13 (17-May-2015)
/dev/nvme0n1p2 is mounted.
e2fsck: Cannot continue, aborting.

Coincidentally, I am also seeing this fuzzy rainbow thing on the outside of desktop windows:

enter image description here

But now the machine won't even boot up at all.

  • 2
    Did you have a system crash or power failure or something that? "recovering journal" probably indicates that the filesystem is cleaning itself it up have not been marked as closed cleanly. That should complete and allow normal startup. If you're not able to complete bootup, post more details - do you get a grub menu? How far does bootup progress? – Joe P Jun 10 '17 at 21:50
  • 1
    The fsck message in your first image is a normal message that indicates that your file system is clean. That's a good thing. It's hard to figure out your second image, but I suspect that you've got a Nvidia video card, and have installed drivers from the Nvidia web site, and you should be using the Nvidia driver from the Ubuntu repositories instead. The journal thing could be a problem... do you have any drivers installed in Windows that allow you to access EXT4 partitions? Do you know how to manually run fsck? Is your system crashing? – heynnema Jun 11 '17 at 0:08
  • Yeah this is not a dual boot machine, it's all Ubuntu, if that adds any info...not sure how to manually run fsck...system is not crashing, but today I turned it off, and it won't boot up again, the "recovering journal" message stays on the screen. – Alexander Mills Jun 11 '17 at 1:30
  • Please see my partial answer. – heynnema Jun 11 '17 at 13:50
  • note that I had to take a photograph with my mobile phone since a screenshot from the machine would have been impossible lol – Alexander Mills Nov 7 '17 at 18:35
6

Step #1:

Lets first check your file system for errors.

To check the file system on your Ubuntu partition...

  • boot to the GRUB menu
  • choose Advanced Options
  • choose Recovery mode
  • choose Root access
  • at the # prompt, type sudo fsck -f /
  • repeat the fsck command if there were errors
  • type reboot

If for some reason you can't do the above...

  • boot to a Ubuntu Live DVD/USB
  • start gparted and determine which /dev/sdaX is your Ubuntu EXT4 partition
  • quit gparted
  • open a terminal window
  • type sudo fsck -f /dev/sdaX # replacing X with the number you found earlier
  • repeat the fsck command if there were errors
  • type reboot
| improve this answer | |
  • 2
    thanks working on it now. shift did not work to get into GRUB menu, but esc key did work. – Alexander Mills Jun 12 '17 at 3:27
  • Ughh, I tried fsck, and I got to an impasse it seems - see updated question, thanks. – Alexander Mills Jun 12 '17 at 3:41
  • ok somehow the fsck command seemed to fix things, so was able to reboot and it worked. Strangely, though, in the intermediate, it would log me as a guest, and no password I tried would work for the guest account, even an empty password..pretty annoying. – Alexander Mills Jun 12 '17 at 4:02
  • Did you really get the fsck to run? Your update to your question shows that it didn't because the / disk was still mounted. If that's the case, I can give you a command which will allow you to get past that. Are you fully booted up then? Let me know. – heynnema Jun 12 '17 at 9:39
  • 1
    Did fsck print out pass 1, pass 2, etc., or give you the "disk is mounted" error as the edit to your question indicates? – heynnema Jun 13 '17 at 13:10

Not the answer you're looking for? Browse other questions tagged or ask your own question.