0

I am running Ubuntu 17.04 on a Dell desktop computer.I have not been able to update ClamAV/ClamTK virus signatures for some time. The antivirus signatures number is "23296." When I try sudo freshclam I get the following error messages:

ERROR: Can't open /var/log/clamav/freshclam.log in append mode (check permissions!).
ERROR: Problem with internal logger (UpdateLogFile = /var/log/clamav/freshclam.log).

This might be related: I am unable to change the scheduled time for daily updates or a daily scan.

Any assistance would be greatly appreciated.

  • I can't put my question into a comment, so I'll have to use an answer to ask... give me a couple of minutes to write it. – heynnema Jun 11 '17 at 0:24
0

Step #1:

In terminal...

cd /var/log
ls -al

Do you see an entry that looks like this...

drwxr-xr-x  2 clamav  clamav 4.0K Jun  4 07:35 clamav/

Does yours look different?

cd clamav
ls -al

Do you see an entry that looks like this...

-rw-r-----  1 clamav adm     68K Jun 10 16:49 freshclam.log

Does yours look different?

Step #2:

Since you indicate that you can't find either of these directory entries, I can only assume that your clamav installation is incomplete. I'd remove it, and then reinstall it, like so...

sudo apt-get purge clamav clamtk
sudo apt-get install clamav clamtk

Step #3:

  • delete the current schedules in the clamtk scheduler by clicking the - icons
  • in terminal...

    sudo apt-get purge clamav clamtk

    cd

    rm -r .clamtk

    sudo apt-get install clamav clamtk

  • reinstall clamtk_5.24-1_all.deb

  • open clamtk, click scheduler, enter times, then click the + icons
  • Actually, I'm not seeing either of those entries. When I enter the first two sets of commands, I do not get a clamav entry. When I type "cd clamav" it says "bash: cd: clamav: No such file or directory." – Michael E. Lynch Jun 11 '17 at 3:03
  • Michael... please see Step #2 in my answer. Report back. – heynnema Jun 11 '17 at 3:25
  • That seems to have updated my virus definitions. However, "sudo freshclam" still provides the same error messages (is it locked because clamtk has a setting to update definitions every day?) and I cannot change the time of the daily scan and update. – Michael E. Lynch Jun 11 '17 at 20:51
  • You have to delete the existing time rule and then you can set a new time rule. – heynnema Jun 11 '17 at 20:58
  • I tried that, but it is not saving the changes in ClamTk. Now, neither is saved. Is there a place to change these settings besides using ClamTK-->Configuration-->Scheduler? Seems like this GUI is not working correctly in Ubuntu 17.04. – Michael E. Lynch Jun 11 '17 at 22:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.