0

I have tried to plug in smaller sd cards like 8gb and it seemed to mount just fine. My 64 gb sd card sometimes does mount if I run

sudo apt-get install --reinstall udisks2

and

sudo depmod

then also restart and that only worked a few times. The sd card is in exfat format and works fine in my windows partition. I have tried a lot of stuff that I could find. Does anyone also have this and how can I fix it?

*-disk                  
       description: ATA Disk
       product: TOSHIBA MQ02ABF1
       vendor: Toshiba
       physical id: 0.0.0
       bus info: scsi@2:0.0.0
       logical name: /dev/sda
       version: 1E
       serial: 26BQCJ0IT
       size: 931GiB (1TB)
       capabilities: gpt-1.00 partitioned partitioned:gpt
       configuration: ansiversion=5 guid=ce85788c-fcdb-45fe-97c8-ffcb78c6e4fa logicalsectorsize=512 sectorsize=4096
maksim@ideapad-15ISK:~$ sudo fdisk -l
Disk /dev/loop0: 79.5 MiB, 83349504 bytes, 162792 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

Disk /dev/loop1: 820.9 MiB, 860745728 bytes, 1681144 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


Disk /dev/sda: 931.5 GiB, 1000204886016 bytes, 1953525168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: CE85788C-FCDB-45FE-97C8-FFCB78C6E4FA

Device          Start        End   Sectors   Size Type
/dev/sda1        2048     534527    532480   260M EFI System
/dev/sda2      534528     567295     32768    16M Microsoft reserved
/dev/sda3      567296  945545215 944977920 450.6G Microsoft basic data
/dev/sda4   945545216 1691889663 746344448 355.9G Microsoft basic data
/dev/sda5  1691889664 1932922879 241033216   115G MBR partition scheme
/dev/sda6  1932922880 1949347839  16424960   7.9G MBR partition scheme
/dev/sda7  1949425664 1951473663   2048000  1000M Windows recovery environment
/dev/sda8  1951475712 1953523711   2048000  1000M Lenovo boot partition
0

Try running lshw -class disk or sudo fdisk -l in the terminal, then locate the name of the sd you want to mount.

Then run sudo ntfs-3g /dev/sd? /media/? -o force replace the '?' with the drive name and mount-point.

The driver mount-point can be anything... For example, you could create a directory /media/external.

(To create the directory, use sudo mkdir /media/external)

don't forget to up-vote and accept it if it works

7
  • i added what I got from running both commands
    – maks112v
    Jun 10 '17 at 21:05
  • was the media card plugged in when you did this?
    – Beulah
    Jun 10 '17 at 21:36
  • I did it right after you sent me the reply yes the media card was plugged in
    – maks112v
    Jun 10 '17 at 21:42
  • if it's not showing there, then I think there has been physical damage to your sd card. Consider replacing it but keep it in case someone comes along with a better method to fix it.
    – Beulah
    Jun 10 '17 at 21:59
  • I have work in Ubuntu every once in a while and I also have it worked every time in Windows
    – maks112v
    Jun 10 '17 at 22:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.