1

I have tightvncserver running with the default settings on my Xubuntu 17.04 system, but when I connect to it on the local network (from Windows or Debian), I only get a grey screen with a cursor. It looks like this:

Grey Screen Xubuntu

This seems to be a common issue for a long time now.

Now while researching, I've seen plenty of people solve the problem by editing the ~/.vnc/xstartup file.

Adding this:

#!/bin/sh
def
export XKL_XMODMAP_DISABLE=1
unset SESSION_MANAGER
unset DBUS_SESSION_BUS_ADDRESS

gnome-panel &
gnome-settings-daemon &
metacity &
nautilus &
gnome-terminal &

I want to see and be able to navigate on my desktop. But I don't think that any of the above programs are relevant for that functionality on a Xubuntu machine.

How would I have to adapt this solution to work for me on Xubuntu 17.04?

5

I don't think it's an "issue for a long time", so much as a misunderstanding about how VNC works.

First, if by "navigate on my desktop" you mean to interact with an existing physical desktop session, then stop reading now and install one of the desktop sharing VNC servers, such as x11vnc or Vino.


If you want a like-for-like replacement of Gnome components by XFCE components, then as near as I can tell that would be:

        Gnome         |      Component     |      XFCE       |
======================+====================+=================+
gnome-panel           |    Application     | xfce4-panel     |
                      | launcher / taskbar |                 |
gnome-settings-daemon |  Settings manager  | xfsettingsd     |
metacity              |   Window manager   | xfwm4           |
nautilus              |    File manager    | pcmanfm         |
gnome-terminal        | Terminal emulator  | xfce4-terminal  |
-------------------------------------------------------------+

so you could convert the gnome-based xstartup file to:

#!/bin/sh

export XKL_XMODMAP_DISABLE=1
unset SESSION_MANAGER
unset DBUS_SESSION_BUS_ADDRESS

xfce4-panel &
xfsettingsd &
xfwm4 &
pcmanfm &
xfce4-terminal &

However, that will still give you a "VNC grey screen" (albeit one with an application launcher, file manager, and terminal emulator). To get the familiar xfce4 blue desktop background you will probably want to add xfdesktop, giving:

#!/bin/sh

export XKL_XMODMAP_DISABLE=1
unset SESSION_MANAGER
unset DBUS_SESSION_BUS_ADDRESS

xfce4-panel &
xfsettingsd &
xfwm4 &
xfdesktop &
pcmanfm &
xfce4-terminal &

Alternatively, instead of starting the components individually, you could simply run startxfce4 directly from your ~/.vnc/xstartup file.

  • Thank you very much. I installed x11vnc and it worked right away as intended. Just my webcam isn't able to display over VNC, but that is another issue. – Handsalot Jun 11 '17 at 8:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.