So I installed the drivers for my phone (Mediatek) and then I connected it through usb cable after which was recognized by my PC. I transferred some files from the PC to the phone and after it was done, I left it plugged into the PC for it to charge. After a few moments, I accidentally pulled the usb cable from the laptop's USB port. The device was still displayed on the taskbar (the one on the left side of the desktop) but when I tried to open it, it displayed an error message which stated that the device is not connected. I reconnected it again but my PC did not recognize it anymore.

EDIT: I already tried rebooting but still doesn't recognize my phone

  • Well, I have such an experience on FreeBSD but not Ubuntu. On FreeBSD sometimes my usd device is not recognized, then I have to power_off the usb port and then power_on it again with command usbconfig. I'm not sure if it can help you, but maybe you can get a hint
    – Megidd
    Jun 10, 2017 at 15:05
  • 1
    Hmm based on what you said and what I researched in the internet maybe restarting the USB ports may be the fix for this. I'm still finding a question for restarting undetected usb ports, though most questions are mostly malfunctioning usb devices. Very much obliged for your tip!
    – jokeyx10
    Jun 10, 2017 at 15:55
  • I tried to do 'dmesg' from askubuntu.com/questions/178054/… and as I skimmed through I noticed this error message in the usb portion [ 9.706604] usb 3-2: device not accepting address 6, error -71 [ 9.706637] usb usb3-port2: unable to enumerate USB device Any ideas how to fix this?
    – jokeyx10
    Jun 10, 2017 at 16:11
  • The device does not show up when I try lsusb. From memory, I remembered it was a Mediatek device, but it does not show up in the list.
    – jokeyx10
    Jun 10, 2017 at 16:31
  • While searching through Google, I came up with the idea that maybe reinstalling the drivers may help resolve this problem, since that's what I do most of the time when I was still using Windows. Can this also be a solution?
    – jokeyx10
    Jun 10, 2017 at 16:57

1 Answer 1


I had the idea of trying other usb cables attempted to do one and it did work. It was all just a hardware problem after all.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .