4

I've updated my Ubuntu distro, and since then everytime I boot the system I am stuck at the fsck screen

/dev/sda1: clean xxx/xxx files, xxx/xxx blocks

I`ve already trying accessing tty and installing xorg and/or nvidia drivers but keep getting the same error message from sudo apt-get install:

apt-get: relocation error: /usr/lib/x86_64-linux-gnu/libapt-pkg.so.5.0: symbol....

I had a GPU installed in my system at the time of the distro upgrade, but I've also tried a multitude of "fixes" with the GPU deactivated by the BOOT settings and none seem to work neither.

Can anyone help me with that? Thanks

Edit 1: Following the demand on a comment, I loged into recovery root and:

# sudo blkid 
/dev/sdb: PTUUID="000d2ed6" PTTYPE="dos"
/dev/sata1: UUID="6ad5e12f-8d6f-4659-b5d4-8fe9eb9d11df" TYPE="ext4" PARTUUID="c537cdcf-01"

# cat /etc/fstab/
# /etc/fstab: static file system information
# 
# Use 'blkid' to print the universally unique identifier for a 
# device; this may be used with a UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options>     <dump>   <pass>
# / was on /dev/sda1 during installation
UUID=6ad5e12f-8d6f-4659-b5d4-8fe9eb9d11df /     ext4    errors=remount-ro  0     1

# free -h
           total     used    free    shared    buff/cache    availabe
Mem:        7.7G      37M    7.5G      8.2M          162M        7.4G
Swap:         0B       0B      0B

# swap on
# _ (no output here)
  • 1
    If you can get to recovery mode from the GRUB menu, and go to root access, show me these commands... sudo blkid, cat /etc/fstab, free -h, and swapon. Edit that info into your question please. Start comments to me with @heynnema or I may miss them. – heynnema Jun 9 '17 at 23:49
  • @heynnema edited the question with the data you asked for. Than you. – Imperian Jun 10 '17 at 13:48
  • Thanks for the info. It all looks good, except that you've got no swap partition or /swapfile. That's not causing your current problem, but it's something that needs fixing. Please see my partial answer and we'll check your file system first. What is on sdb? Report back. – heynnema Jun 10 '17 at 13:55
  • @heynnema I had some USB connections to a development board I was working on, I believe sdb is one of those. – Imperian Jun 10 '17 at 14:01
  • Does it boot if you disconnect sdb? Let me know about the fsck. – heynnema Jun 10 '17 at 14:03
1

I finally managed to fix my problem. It looks like it was caused by issues from PPA for Ubuntu toolchain. I downloaded (from tty terminal) the debian of package libstdc++6 for Xenial at http://packages.ubuntu.com/xenial/libstdc++6

In my case (amd64) I did the following (on tty, Cntrl + Alt + F1 on the "error" screen):

# wget http://security.ubuntu.com/ubuntu/pool/main/g/gcc-5/libstdc++6_5.4.0-6ubuntu1~16.04.4_amd64.deb
# dpkg -i libstdc++6_5.4.0-6ubuntu1~16.04.4_amd64.deb
# reboot

And voilà, that solved the problem :)

  • How did you figure that out? You should still create a swap partition or a /swapfile. You can accept your own answer to close the question. – heynnema Jun 10 '17 at 14:42
  • As @heynnema mentioned, how did you realize libstdc++6 is the cause of the issue? – user3405291 Jun 10 '17 at 15:25
  • I figured out that apt-get was not working, then I looked out for a fix (so that I could reinstall the video drivers), and ended out finding a forum post where someone mentioned that his computer was not booting because of the same problems I had on apt-get. Then I fixed it and everything is working fine again. – Imperian Jun 10 '17 at 15:32
0

If you recently installed nvidia drivers, you might have disabled nouveau drivers. In my case I managed to fix this by removing every occurrence of nomodeset from /etc/default/grub file and then by executing sudo update-grub.

This was because nomodeset disables the use of any graphic driver. I disabled my nouveau drivers before installing nvidia ones.

Though this might not be the case with everyone.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.