hello everyone i am new to Linux Mint 17 and enthusiastic for learning,adopting and sharing linux.my experience with linux is all good except now i am unable to constatnly connect to my network same network is running very smoothly on my fellow's windows 10.i read every thread regarding this and applied all commands and i think i am mess up too. here is what my problem

wifi keep disconnects

output of ‍sudo lspci -vnn | grep Network‍:

01:00.0 Network controller [0280]: Ralink corp. Device [1814:539a]

output of *iwconfig*  
 eth0      no wireless extensions.

lo        no wireless extensions.

wlan0     IEEE 802.11bgn  ESSID:"WI-FI-LH"  
          Mode:Managed  Frequency:2.412 GHz  Access Point: [REDACTED]   
          Bit Rate=43.3 Mb/s   Tx-Power=20 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=43/70  Signal level=-67 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:82334  Invalid misc:6464   Missed beacon:0

here is what i have done reading help threads

installed firmware-b43-installer b43-fwcutter

i have add iwconfig wlan0 rate 54M in /etc/rc.local

i put a # infront of the line blacklistbcm43xx in etc/modprobe/blacklist.conf

i also tried wicd but then unistall because it wasnt satisfactory

looking forward for any help which could solve my wifi issue and increase speed of my wifi(i mean speed that i was enjoying in windows os) any help will be highly appreciated.i have also surf 10 to 15 days searching for help so if you please help me on priority bases i will be thankfull because these are my exams days.

  • So this is Ubuntu 17.04 that you are running? Because Ubuntu is not Linux, it's just a distribution. In fact, Linux is really only the kernel.
    – user364819
    Jun 9, 2017 at 21:50
  • no i am using linux.am i not allowed to ask question about linux?sorry i am new i dont know:(
    – forlorn
    Jun 9, 2017 at 22:20
  • You will be using a Linux distribution, you can't just be using the kernel. Or are you? Where did you download the ISO from to install this?
    – user364819
    Jun 10, 2017 at 10:45
  • sorry i was silly not to understand your question:) i a using linux mint qiana
    – forlorn
    Jun 10, 2017 at 15:10
  • 1
    Although Linux Mint is based on Ubuntu, it is not Ubuntu and thus not supported on this site. You will find Unix & Linux to be better suited to future questions.
    – user364819
    Jun 10, 2017 at 21:09

1 Answer 1


The driver for your device, rt2800pci is notoriously tricky. Neverthe less, there are some things we might try.

First, check the settings in the router. WPA2-AES is preferred; not any WPA and WPA2 mixed mode and certainly not TKIP. Second, if your router is capable of N speeds, you may have better connectivity with a channel width of 20 MHz in the 2.4 GHz band instead of automatic 20/40 MHz, although it is likely to affect N speeds. I also have better luck with a fixed channel, either 1, 6 or 11, rather than automatic channel selection. Also, be certain the router is not set to use N speeds only; auto B, G and N is preferred. After making these changes, reboot the router.

Then set your regulatory domain explicitly. Check yours:

sudo iw reg get

If you get 00, that is a one-size-maybe-fits-all setting. Find yours here: http://en.wikipedia.org/wiki/ISO_3166-1_alpha-2 Then set it temporarily:

sudo iw reg set IS

Of course, substitute your country code if not Iceland. Set it permanently:

gksudo gedit /etc/default/crda

Use nano or kate or leafpad if you don't have the text editor gedit.

Change the last line to read:


Proofread carefully, save and close the text editor.

Next, I'd set IPv6 to Ignore in Network Manager: http://docs.fedoraproject.org/en-US/Fedora/18/html/Installation_Guide/images/netconfig/network-connections-ipv6-ignore.png This example is for ethernet, but you want wireless.

If these changes do not help, please try:

sudo modprobe -r rt2800pci
sudo modprobe rt2800pci nohwcrypt=1

After trying it for a few hours, if it helps, make it permanent:

sudo -i
echo "options rt2800pci nohwcrypt=1"  >>  /etc/modprobe.d/rt2800pci.conf

We might also disable power saving in Network Manager:

sudo sed -i 's/3/2/' /etc/NetworkManager/conf.d/*

Finally, I worked on a recent case where N speeds in the router were actually slower! Please try setting your router to 802.11B and G without N.

  • thank you so much for your quick reply.i am student and i am using Internet of hostel so i cant edit/check settings of router.although it seems good because my other mates running windows are enjoying high speed without any issue i have set regdomain to my country(can you please tell me does it matters and how because i want to learn too) and what does modprobe commands do
    – forlorn
    Jun 9, 2017 at 22:35
  • The regdom aligns the capabilities of the router and your wireless card with respect to channels, transmit power and more. The modprobe commands first unload the driver module and then load it back again with a (possibly) helpful parameter. If you are unable to address the settings in the router, then do all the steps that you can do and we hope for improvement.
    – chili555
    Jun 10, 2017 at 12:36

Not the answer you're looking for? Browse other questions tagged or ask your own question.