2

I know its a common issue, but I couldn't find a solution online.

I downloaded the ISO (32 bit) from here: http://lubuntu.net/blog/lubuntu-1610-yakkety-yak-released

I mounted the guest additional from input -> insert guest additions CD image.

Then I started VBoxLinuxAdditions.run.

I enabled shared clipboard and drag and drop, neither work Nor does the shared folder I tried to mount.

I figure the problem is something with the guest additions - but every time I try to install again, it says that its updated.

When I try running modprobe vboxsf , as I have seen suggested, I get ERROR: could not insert 'vboxsf': Operation not permitted.

Also used sudo gpasswd -a username vboxsf to add myself to the user group, it said it worked but then again, the above operations still aren't working.

modinfo vboxsf output:

filename:       /lib/modules/4.8.0-22-generic/misc/vboxsf.ko
version:        5.1.18 r114002
alias:          fs-vboxsf
license:        GPL
author:         Oracle Corporation
description:    Oracle VM VirtualBox VFS Module for Host File System Access
srcversion:     B90FAA646E076EF187EC29B
depends:        vboxguest
vermagic:       4.8.0-22-generic SMP mod_unload modversions 686 
parm:           follow_symlinks:Let host resolve symlinks rather than showing them (int)

dpkg -l *virtualbox* | grep ii output :

bar@bar-VirtualBox:~$ dpkg -l *virtualbox* | grep ii
ii  virtualbox                     5.1.6-dfsg-2 i386         x86 virtualization solution - base binaries
ii  virtualbox-dkms                5.1.6-dfsg-2 all          x86 virtualization solution - kernel module sources for dkms
ii  virtualbox-guest-additions-iso 5.1.6-1      all          guest additions iso image for VirtualBox
ii  virtualbox-guest-dkms          5.1.6-dfsg-2 all          x86 virtualization solution - guest addition module source for dkms
ii  virtualbox-guest-source        5.1.6-dfsg-2 all          x86 virtualization solution - guest addition module source
ii  virtualbox-guest-utils         5.1.6-dfsg-2 i386         x86 virtualization solution - non-X11 guest utilities
ii  virtualbox-guest-x11           5.1.6-dfsg-2 i386         x86 virtualization solution - X11 guest utilities
ii  virtualbox-qt                  5.1.6-dfsg-2 i386         x86 virtualization solution - Qt based user interface
bar@bar-VirtualBox:~$ 
  • Can you post all the error messages? – Arun Jun 9 '17 at 18:38
  • Did you log out/in after putting username in group vboxsf? That'll fix your shared folder problem. Clipboard and drag/drop has always been a problem. Are you running VB 5.1.22? – heynnema Jun 9 '17 at 19:08
  • @Arun For which commands? The only real 'error' I encountered is the modprobe one, but still, it doesn't work. – Gray Jun 9 '17 at 19:26
  • You mean modprobe: FATAL: Module vboxdrv not found.? – Arun Jun 9 '17 at 19:28
  • @heynnema I restarted the VM, but I still don't have access to the shared folder in /media/shared_name, even tho auto-mount is on. I'm not sure how to check the VB version? – Gray Jun 9 '17 at 19:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.