0

I configured my system to be in English except for keyboard, time and units It's been working as expected until now. Today dpkg, apt-get and apt-cache started to report in Turkish.

When I type dpkg xxx I get the error in Turkish:

dpkg: hata: bir eylem seçeneği belirtilmesi gerekiyor

Paket kurma ve kaldırma hakkında yardım almak için dpkg --help yazın [*];
Kullanıcı dostu paket yönetimi için 'apt' veya 'aptitude' araçlarını kullanın;
dpkg ile kullanabileceğiniz hata ayıklama bayraklarının listesini görmek için
dpkg -Dhelp yazın;
Zorlama seçeneklerinin listesini görmek için dpkg --force-help yazın;
*.deb dosyalarını değiştirme hakkında bilgi almak için dpkg-deb --help yazın;

[*] ile işaretlenmiş komutlar çok miktarda çıktı üretir - 'less' ya da
'more' araçları ile birlikte kullanın !

or when I type sudo apt-get xxx:

E: Geçersiz işlem: xxx

The result of locale is

LANG=en_US.UTF-8
LANGUAGE=en_US:tr
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC=tr_TR.UTF-8
LC_TIME=tr_TR.UTF-8
LC_COLLATE="en_US.UTF-8"
LC_MONETARY=tr_TR.UTF-8
LC_MESSAGES="en_US.UTF-8"
LC_PAPER=tr_TR.UTF-8
LC_NAME=tr_TR.UTF-8
LC_ADDRESS=tr_TR.UTF-8
LC_TELEPHONE=tr_TR.UTF-8
LC_MEASUREMENT=tr_TR.UTF-8
LC_IDENTIFICATION=tr_TR.UTF-8
LC_ALL=

I failed to find a way to change the language setting of these specific commands. It's very frustrating that something like that changes without me changing it.

I have tried sudo dpkg-reconfigure locales, nothing changed.

0

1 Answer 1

2

This line in the locale output is probably the culprit:

LANGUAGE=en_US:tr

You need to figure out in which file that is set, and change it to e.g.:

LANGUAGE=en_US:en
1
  • Well, this was embarrassing. Thank you so much
    – timuçin
    Jun 17, 2017 at 8:59

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .