0
root@prateek-desktop:/root/ptbridge-master# java -jar ptbridge.jar
OpenJDK Server VM warning: You have loaded library /tmp/packetsocket5426320610063427559 which might have disabled stack guard. The VM will try to fix the stack guard now.
It's highly recommended that you fix the library with 'execstack -c <libfile>', or link it with '-z noexecstack'.
Exception in thread "main" java.lang.UnsatisfiedLinkError: /tmp/packetsocket5426320610063427559: /tmp/packetsocket5426320610063427559: wrong ELF class: ELFCLASS64 (Possible cause: architecture word width mismatch)
    at java.lang.ClassLoader$NativeLibrary.load(Native Method)
    at java.lang.ClassLoader.loadLibrary1(ClassLoader.java:1968)
    at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1893)
    at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1854)
    at java.lang.Runtime.load0(Runtime.java:795)
    at java.lang.System.load(System.java:1062)
    at at.stefl.packetsocket.NativeLibraryLoader.load(NativeLibraryLoader.java:41)
    at at.stefl.packetsocket.EthernetSocket.<clinit>(EthernetSocket.java:78)
    at at.stefl.ptbridge.main.Main.main(Main.java:49)

Can some one please help in resolving these exceptions ?

2
  • You have a mismatch between 32bit and 64bit libraries it needs, it seems, by the error referenced about ELF class. What architecture is your system, and have you checked what architecture you need to run packet tracer?
    – Thomas Ward
    Commented Jun 9, 2017 at 14:35
  • my ubuntu is 32 bit and i guess i need to install 64 bit ubuntu . Is it ? Commented Jun 9, 2017 at 15:31

1 Answer 1

0

The core problem is a mismatch in the libraries being expected. An ELFCLASS64 file is designed for 64-bit libraries, not 32-bit.

As you stated in comments, you have 32-bit Ubuntu; this means you have 32bit libraries and cannot execute 64-bit programs. You will need to install and run 64-bit Ubuntu if your architecture supports it, so that you can have the proper version of the libraries necessary to run Packet Tracer Bridge.

If your system does not support a 64-bit OS then you will either need to see if Packet Tracer Bridge has a 32-bit version, or you will have to replace your computer with one that supports 64-bit operating systems, or you will have to just not use Packet Tracer Bridge.

1
  • Thanks alot for your feedback i will try using 64 bit ubuntu if my PC supports it. (Y) Commented Jun 9, 2017 at 15:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .