4

First an foremost: I am a absolute Linux beginner, so have mercy if my problem seems easy to you. My Brother gave me his old T420, so I decided to learn Linux and install Ubuntu on it. Unfortunately I can't establish a WiFi connection (my brother assured me it worked when he used it) so I'm pretty positive it's not a Hardware problem. In the terminal he finds the Network adapter when I type

lspci
03:00.0 Network controller: Intel Corporation Centrino Advanced-N 6205 [Taylor Peak] (rev 34)

I'm pretty sure I'm missing the required drivers, but I cant find a way to download them, as I'm used to just download them directly from the manufacturers site under windows. Sorry if I seem so super stupid, but this is all pretty new for me. Here are the commands I found in other threats:

ifconfig

enp0s25   Link encap:Ethernet  HWaddr 00:21:cc:5e:b2:30  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:3069 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2616 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:2298050 (2.2 MB)  TX bytes:316024 (316.0 KB)
          Interrupt:20 Memory:f2500000-f2520000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:3819 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3819 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1 
          RX bytes:257315 (257.3 KB)  TX bytes:257315 (257.3 KB)

sudo rfkill list

0: tpacpi_bluetooth_sw: Bluetooth
    Soft blocked: yes
    Hard blocked: yes
1: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: yes

sudo lshw -class network

*-network               
       description: Ethernet interface
       product: 82579LM Gigabit Network Connection
       vendor: Intel Corporation
       physical id: 19
       bus info: pci@0000:00:19.0
       logical name: enp0s25
       version: 04
       serial: 00:21:cc:5e:b2:30
       size: 1Gbit/s
       capacity: 1Gbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=e1000e driverversion=3.2.6-k duplex=full firmware=0.13-3 ip=192.168.178.29 latency=0 link=yes multicast=yes port=twisted pair speed=1Gbit/s
       resources: irq:24 memory:f2500000-f251ffff memory:f252b000-f252bfff ioport:5080(size=32)
  *-network DISABLED
       description: Wireless interface
       product: Centrino Advanced-N 6205 [Taylor Peak]
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: wlp3s0
       version: 34
       serial: a0:88:b4:4b:94:3c
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=4.8.0-36-generic firmware=18.168.6.1 latency=0 link=no multicast=yes wireless=IEEE 802.11
       resources: irq:29 memory:f2400000-f2401fff

dmesg | grep iwl

[   10.492168] iwlwifi 0000:03:00.0: can't disable ASPM; OS doesn't have ASPM control
[   10.702888] iwlwifi 0000:03:00.0: loaded firmware version 18.168.6.1 op_mode iwldvm
[   10.914050] iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_DEBUG disabled
[   10.914052] iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_DEBUGFS enabled
[   10.914052] iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_DEVICE_TRACING enabled
[   10.914054] iwlwifi 0000:03:00.0: Detected Intel(R) Centrino(R) Advanced-N 6205 AGN, REV=0xB0
[   10.915537] iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
[   10.915748] iwlwifi 0000:03:00.0: RF_KILL bit toggled to disable radio.
[   10.950926] ieee80211 phy0: Selected rate control algorithm 'iwl-agn-rs'
[   12.287868] iwlwifi 0000:03:00.0 wlp3s0: renamed from wlan0

sudo iwlist scan

enp0s25   Interface doesn't support scanning.

lo        Interface doesn't support scanning.

wlp3s0    Interface doesn't support scanning : Network is down

Sorry for spamming, I just wanted to make sure you got everything you might need. Also, as another piece of information, when I start the PC, right before he boots Ubuntu, the screen shows the Intel Boot Agent. He shows a new line, saying: DHCP... and waits there for 30 seconds, after that he states that something is missing (too short for me to read) and goes on. Everywhere I look it says, that most of the drivers are included in Ubuntu and if someone had this problem, he was running on an old release. Im using 16.04.2, but I also tried 17.04 - without a change. Even Intel states, that this device is supported by Ubuntu.

Ethernet is working fine, btw.

If anyone is willing to help me - thanks. I'm sitting here for 6 hours and cant figure it out. Thanks in advance.

2
  • 2
    Everything is OK with drivers. The problem is with rfkill block. Check hardware switch or bios settings.
    – Pilot6
    Jun 9, 2017 at 10:26
  • Wow, that was quick. Thanks, i will check it out.
    – willbert
    Jun 9, 2017 at 10:28

1 Answer 1

2

Now I'm feeling even dumber then 5 mins ago when posting this. There was indeed a tiny little switch on the side of the Notebook, disabling all wireless traffic. If I knew about this, the last hours wouldnt have been such a struggle. Thanks Pilot6 for the hint. I'm feeling to ashamed leaving this post, but I will, maybe it will help others... Case closed.

1
  • Yes I feel like an idiot, it even shut down a known good usb adapter. However it is a new-to-me computer and who would have thought it. Thanks for the post, who knows how much time it saved me, always looking for the tricky solution.
    – Dennis
    Jul 31, 2017 at 1:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.