I just installed ubuntu 16.04. I have the problem that wifi cannot reconnect in any way after a long time sleep or suspend or hibernate( I leave the computer until next day ).

I googled, I've tried any method I can find online, but they don't work:

  1. I followed this thread, edit the /etc/NetworkManager/NetworkManager.conf, but it's not working

  2. this thread, run the command: systemctl restart network-manager.service

  3. sudo killall NetworkManager && sudo NetworkManager

  4. $ sudo nmcli networking off
    $ sudo nmcli networking on
  5. $ sudo ifdown -a
    $ sudo ifup -a
  6. sudo ifconfig wlp4s0 up
    service network-manager restart

I don't know whether my problem is caused by this bug, but I don't see the fix for this bug: https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/1574347

nmcli dev shows that the type is wifi, but it is disconnect, I can't make it reconnect except reboot system.

Can someone help me?

  • I have the same problem. After a lot of research the prevailing wisdom was that it is a bug. I've been through a few upgrades since, but still running 16.04. Haven;t tried it recently. If I need to be away from the computer for a while I just use the lock account feature. Recovery from suspend is painful if not impossible. After having to reboot a few times I just quit using it. – jones0610 Jun 9 '17 at 3:25
  • There's some good information at askubuntu.com/questions/845800/… No clear solutions but the advice involves fooling with power management. – jones0610 Jun 9 '17 at 3:46
  • @jones0610, thanks!! I'll try it out. – Aaron Shen Jun 9 '17 at 3:48
  • This might help out: askubuntu.com/questions/898297/… – WinEunuuchs2Unix Jun 9 '17 at 5:33

I recently had this problem with Elementary OS. I tried everything under the Google sun, but the only thing that solved my problem was to do a very hard turning off and on by reinstalling the OS.

I understand that this is not thy type of answer you were looking for, but it is a potentially valid solution, if all else fails. I believe that there is a prolific variety of Q&A on this very problem through the Internet. I encourage you to look through these and to report the results here.

  • This answer does not address the question being asked. In addition, reinstalling the OS will definitely NOT solve this problem. – jones0610 Jun 9 '17 at 3:41
  • It did in my case – MountainClimberi Jun 9 '17 at 3:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.