3

I just bought the new Dell XPS 9360.

I've had two main issues after installing latest Ubuntu:

  • touchpad config, which I fixed thanks to this post
  • wifi being reallllllly slow, not all the time, not on every wifi, but too often. Most of the time it starts by working reasonably, until falling down to super slowness interrupted by temporary disconnections...

I read several things on the topic, but until now without success:

  • This one did not have any observable effect
  • This post seems to relate to an old kernel-header issue so I doubt it still applies
  • In there: I tried several tips, without success for now

Anyone experiencing this? Any fix to offer? Or at least some tips to investigate (where are the logs, what are the layers on the network config in linux, what is modprobe.d, why does ath10k lives along several other versions in /lib/firmware etc.)

Using:

$ apt-cache search linux-headers-$(uname -r)
linux-headers-4.4.0-79-generic - Linux kernel headers for version 4.4.0 on 64 bit x86 SMP

Cheers


EDIT: Here's the output of lspci -knn | grep Net -A3:

➜  ~ lspci -knn | grep Net -A3
3a:00.0 Network controller [0280]: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter [168c:003e] (rev 32)
    Subsystem: Bigfoot Networks, Inc. QCA6174 802.11ac Wireless Network Adapter [1a56:1535]
    Kernel driver in use: ath10k_pci
    Kernel modules: ath10k_pci
3b:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS525A PCI Express Card Reader [10ec:525a] (rev 01)
5
  • Please edit your question and add output of lspci -knn | grep Net -A3 terminal command. – Pilot6 Jun 8 '17 at 19:53
  • Done. Does it help? – Augustin Riedinger Jun 8 '17 at 21:01
  • I have XPS 9530 and installed Ubuntu 14.04 and do remember having some difficulties with the wireless driver. In my case I had no wireless access and therefore I had to download broadcomm drivers (BCM4352) and its dependencies. Once installed everything was working fine. In your case having a look at drivers page and comparing it with your Atheros card, it seems you are having some driver issues. Here I also found another issue with the wifi. Als – Keivan Jun 14 '17 at 15:48
  • 1
    I'm having the same issue (just got mine). Did you have any success finding a solution? – Linuxios Jul 27 '17 at 16:29
  • Situation is better now: it sometimes fails with old wifi routers, but most of the time it is fine. I guess upgrading the drivers helped. Otherwise in case of great pain, I use my phone wifi as a modem, it saved me several times. – Augustin Riedinger Aug 1 '17 at 10:41
-1

I had the same issue with a HP and realtek wifi card. The repository drivers didn't work the card properly. After searching threads for a couple of days, I finally found (by trial and error) a driver source that worked.

first, try compiling the drivers yourself with (make,make install) to eliminate the possibility of a kernel mismatch. if that doesn't work search for newer drivers. if you get source, it doesn't matter what distro they come from because they will be compiled to match your kernel.

EDIT: try these: wget https://github.com/FireWalkerX/ath10k-firmware/raw/master/QCA6174/hw3.0/board-2.bin

4
  • 1
    So the answer is: "search for some driver and compile it"? How is it helpful? – Pilot6 Jun 14 '17 at 17:32
  • Yes, the answer is keep looking for the right driver. As opposed to trying to find an error in your system. Sometimes, that is it with proprietary drivers. hunt and hunt until you find the right one. it's a driver issue not a distro issue. the manufacture makes little changes and don't release the info so you have to use their drivers. – ravery Jun 14 '17 at 17:56
  • I'd rather being able to investigate on the cause: wouldn't there be errors, logs or whatever? The issue might happen at several levels... And it is slow but it "works" which is weirder than nothing at all – Augustin Riedinger Jun 19 '17 at 21:47
  • mine did the same exact thing until I got the right drivers. slow connection with frequent resets – ravery Jun 19 '17 at 21:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.