I am trying to connect my Ubuntu desktop to a Windows network. I have been following guides like this.

I enabled the network share, but when I try t open my network tab, I do not see my computer and trying to connect to the Windows network results in the following error:

Failed to retrieve share list from server: No such file or directory

net usershare info gives the following:

net usershare info --long

[Network share]
path=/home/molbio/Network share
  • Did you make sure that the client machine can reach the server machine through the network at all via ping etc.? Feb 23, 2018 at 11:48

2 Answers 2


you should have samba file sharing installed. To install samba open terminal and type:

sudo apt-get update
sudo apt-get install samba

you will now have samba file server. To access any shared files you need to open file manager and type ctrl + l this will select your file path url. Follow the syntax mentioned below:

smb://< server-ip-or-host >/
  • I already had this. It doesn't seem to be on the windows network and isn't accessible via Windows machine.
    – user698073
    Jun 9, 2017 at 9:01
  • There's no need to install a Samba server to access SMB shares on a different machine. Feb 23, 2018 at 11:46
  • You need a Samba client. It does not hurt to install the server, but you need the client. The Windows machine is the server. Install cifs-utils as well.
    – mckenzm
    Jun 26, 2018 at 23:27
  • Installing a server does not necessarily install the client software. Instead, you should verify that nautilus-share is installed.
    – jpaugh
    Mar 13, 2021 at 18:06

I have two systems on the home network: System 1 is a Windows 10 machine with two accounts, a standard account and an admin account, both of which use their respective Microsoft accounts to log into their accounts in System 1. The other computer, System 02, has Ubuntu 16.04.3 LTS installed.

I installed the samba package in Ubuntu (System 2) and from the file manager I selected the folders I wanted to share, right clicked and from the menu went into sharing options. Then I checked "Allow others to create and delete files in this folder" and also checked "Guest access" and then clicked "Create Share".

Then on the Windows 10 machine (System 1), I logged into the admin account, and from Control Panel -> Network and Internet -> Network and Sharing Centre -> Advanced Sharing Settings, in "Change sharing options for different network profiles" I selected "Turn on network discovery" and checked "Turn on automatic setup of network connected devices" then clicked "Turn on file and printer sharing" and then saved changes.

This completes the set up for the two systems.

Then back on the Ubuntu machine (System 2) I opened the file manager, and mentioned in a previous post, I clicked Ctrl+l and then in the address box type


A dialog box opens up and I type in the username (which is the windows 10 admin MS account name or email) and typed in the domain of the Windows 10 system (usually WORKGROUP) and password (for the Windows 10 admin MS account). Then the shared folders on the Windows 10 system are displayed.

You must log in to answer this question.