I've never actually been able to get Synergy working, even when using QuickSynergy. Even using this guide gives me nothing; my mouse won't leave the edge of my screen. I've even disabled both computers' ufw firewalls to make sure ports aren't being blocked. What am I doing wrong?

work-macbook, host computer:




work-laptop, slave computer:



Pinging work-macbook from work-laptop works, and pinging work-laptop from work-macbook works. Things are basically working with host-names to IP addresses on my network, so that doesn't seem like the issue:


work-macbook $ ping work-laptop
64 bytes from work-laptop (

work-laptop $ ping work-macbook
64 bytes from work-macbook (
  • Done, sorry about that. – Naftuli Kay Jan 2 '12 at 23:54
  • Have you tried using the IP addresses in the config file for hostname and clientname? – Kendor Jan 3 '12 at 0:47
  • @Kendor Yes I have. Really weird. – Naftuli Kay Jan 3 '12 at 1:56

Have you tried setting up your config file on the host as shown in the synergy docs?

Name the text file ".synergy.conf" in your host home folder.

Something like this:

section: screens

section: links
        left =      work-laptop
        right =     work-macbook

Then run "synergys" on the host and I believe it's "synergyc -a [address]" on the client. You can run synergyc with the -f option to make it run in the foreground, that might tell you something about why it's not working.

  • Evidently, there was a DNS issue, but this conf fixed it and things are working GREAT now. Thanks! I had to run synergyc IPADDRESS – Naftuli Kay Jan 3 '12 at 17:42

To me, in Ubuntu, running synergyc [Server-IP-address] works.

It invokes synergy client daemon with the argument of IP address of the server. When I get problem with synergy on my Ubuntu (client), I just kill the daemon and re-run by this command.

  • 2
    Can you explain what this command does? – Zzzach... Apr 27 at 19:26
  • Its invokes synergy client daemon with the argument of IP address of server. When I got problem with synergy on my ubuntu(client), I just kill the daemon and re-run by this command – Giang Nguyễn Apr 28 at 8:45
  • Add that information to your answer so people know more about it. I asked this because your answer is considerably short, and posting commands without explaining them is looked down upon (security reasons, etc). – Zzzach... Apr 29 at 5:55
  • Its a good advice, will notice for the next time! – Giang Nguyễn Apr 29 at 6:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.